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Prefazione

Fin da quando ho cominciato ad usare gimp per il ritocco delle mie foto,
ho preso l’abitudine di mantenere degli appunti dettagliati (prima su carta,
poi in un file del mio computer) che descrivessero passo per passo le “ricette”
da seguire per raggiungere certi scopi: ricette elaborate a partire dall’on
line help, dai tutorials esistenti e dalla mia esperienza personale; ed ho
colto l’occasione della pensione per far diventare questi appunti un piccolo
libriccino. Attenzione: questo non vuole essere un manuale di fotografia (per
esempio si da per scontato che chi legge sappia cosa sia la profondità di
campo e come controllarla) anche se contiene, nella parte iniziale, qualche
consiglio su come fotografare; né vuole essere un manuale di gimp (per
esempio si da per scontato che chi legge sappia a cosa serve il Clone Tool e
come richiamarlo).

Le voci dei menù di gimp sono citate in inglese, senza tradurle in italiano1:
sul mio computer (su cui c’è un sistema operativo Linux Fedora 11 con gimp

2.6.7) la localizzazione italiana non è stata istallata, perché la ritengo un
inutile spreco di risorse; per distinguere queste voci dal resto del testo ho
usato dei caratteri senza grazie ed una freccia, come ad esempio File → Open.
I nomi dei tools e le frasi che compaiono nella varie finestre di gimp e che
ne rappresentano le possibili opzioni sono invece scritti in corsivo: come, ad
esempio, nella frase Color Picker Tool. È anche sottinteso che esistono molte
differenti tecniche e molte differenti opzioni che consentono di raggiungere
per una foto gli stessi risultati, o quanto meno risultati molto simili: i metodi
che descrivo sono quelli che piacciono a me.

È da notare che diverse immagini di finestre di gimp che ho incluso nel

1So che questo non va bene per la maggior parte delle persone che mi hanno scritto, e
me ne dispiace. Anche se avete istallato l’italiano come ambiente di default, sotto Linux
potete avere gimp in inglese facendolo partire da un terminale con il comando:

LC_MESSAGES=en_US gimp &

v
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testo risalgono alla versione 2.4 del programma; con l’arrivo della 2.6 non ho
ritenuto di doverle rifare. Ho però aggiornato il testo: ad esempio, mentre
per attivare il Layers Dialog con gimp 2.4 bisognava selezionare Dialogs →

Layers, adesso si usa Windows → Dockable Dialogs → Layers.
Esistono, su Internet, molti tutorials su gimp; qualcuno di essi mi è servito

come punto di partenza per alcune delle tecniche per il ritocco delle immagini
descritte nel testo. Un buon punto di partenza per arrivare a questi tutorials
sono queste URL:

http://gimp.org/tutorials/

http://gimptutorials.net/

http://gimp.linux.it/www/docrisorse.html

http://www.youtube.com/

(i primi due siti contengono documentazione in inglese, il terzo in italiano;
YouTube ha videotutorials in ogni lingua). Le raccomandazioni generali sono
poche:

1. per prima cosa lavorate sempre su una copia dell’originale, che deve
essere conservato inalterato — io ad esempio archivio su CD i miei scatti
in formato Canon RAW, e li converto in JPEG o XCF solo per modificarli
e stamparli.

2. Poi, quando siete soddisfatti di un passaggio intermedio e dovete conti
nuare ad elaborare l’immagine, salvatela in caso di disastri o di cambi
di idea — e fatelo spesso, in modo da poter riprendere da quel punto
senza problemi.

3. Questi passaggi intermedi vanno salvati esclusivamente nel formato nati

vo di gimp (XCF): un salvataggio come JPEG introduce sempre un piccolo
deterioramento della qualità dell’immagine; così come ne diminuiscono
la qualità alcune operazioni (ad esempio rotazioni e cambiamento di
dimensioni), se applicate ad una immagine JPEG.

4. Per ultima cosa: se volete giudicare se una modifica appena apportata
è valida o no, usate una rapida sequenza di Edit → Undo e di Edit →

Redo alternati (gli shortcuts sono CtrlZ e CtrlY); è molto più facile
decidere.

Tutte le foto di esempio, salvo quando ne indico esplicitamente la fonte,
sono state fatte da me con la mia Canon EOS 350D; gli obiettivi di cui dispongo
attualmente sono un grandangolo Canon EFS 1022 mm f/3.54.5 USM; un
obiettivo “normale” Canon EFS 1755 mm f/2.8 IS USM; un teleobiettivo Canon
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EF 70200 mm f/4 L IS USM; un moltiplicatore di focale Canon Extender EF
1.4× II; ed infine due obiettivi macro, un Canon EF 100 mm f/2.8 Macro USM
ed un Canon EFS 60 mm f/2.8 Macro USM2. Se siete in grado di estrarre le
immagini dal PDF, sappiate che in tutte le foto di questo tutorial (e che sono
in formato JPEG) sono stati lasciati i commenti Exif .

Posseggo anche una compatta Sony DSCS90 (4.1 megapixels su sensore
da 1/2.7′′, con zoom Zeiss di focale 6÷ 18 mm, equivalenti a 39÷ 117 mm
su FF ed a 24÷ 73 mm su APSC), utilizzata in un paio delle foto incluse.

E, per concludere. . . mandatemi i vostri commenti, le vostre critiche ed i
vostri suggerimenti. Il mio indirizzo email è Maurizio.Loreti@gmail.com;
e vorrei che mi scriveste cosa pensate sia sbagliato, cosa ritenete poco chiaro
o incompleto, cosa vi interessa che io aggiunga a questo tutorial.

2In passato ho posseduto ed usato anche il Canon EFS 1855 mm f/3.55.6 “plasticotto”
ed il Canon EFS 55250 mm f/45.6 IS.





Capitolo 1

Preliminari

1.1 La composizione

All’inizio di ogni fotografia c’è, come primo elemento, l’occhio del fotogra
fo: è quell’occhio che dell’immagine genera l’essenza, l’anima. Molti neofiti
guardano con invidia le attrezzature dei professionisti, e pensano erronea
mente che con macchine fotografiche, obiettivi ed accessori innumerevoli (e
costosi) come i loro non sia possibile non fare belle foto; ma questo è un gros
so errore, perché molti fotoamatori (purché posseggano un minimo di buon
gusto e di esperienza) sono in grado di fare foto migliori di professionisti che
si applichino distrattamente al proprio lavoro. Di sicuro, il primo elemento è
l’occhio del fotografo; secondo me, poi, viene la qualità delle ottiche; e solo
per ultima la macchina fotografica.

Regola numero uno: il fotografo deve vedere quello che c’è da vedere.
Non è così semplice; guardate la foto in figura 1.1: è un esempio di quello
che i giapponesi chiamano wabi, ossia di oggetti consueti e modesti che
normalmente non consideriamo nemmeno ma che, quando li guardiamo con
attenzione, mostrano forme e colori di una grazia ed una completezza estetica
inaspettate. Quando i giapponesi contemplano i rami dei ciliegi appena fioriti
o si perdono nella visione della ghiaia ben pettinata di un giardino zen, stanno
apprezzando l’armonia di qualcosa che è wabi; allo stesso modo, il fotografo
dall’occhio allenato può vedere in una macchia di ruggine, in una corda piena
di panni stesi, nelle fessure della corteccia di una betulla qualcosa di bello —
e scatta la sua foto.

Regola numero due: il fotografo deve vedere tutto quello che c’è da vedere.
Infatti le sensazioni visive sono mediate dal nostro cervello, che fin troppo

1



2 Capitolo 1  Preliminari

Figura 1.1: sassi sulla spiaggia a VilleneuveLoubet (55mm, ISO 400, 1/400s,
f/14).

facilmente si sofferma esclusivamente su quello che ci interessa (una persona
amata, una macchia di colore) piuttosto che su tutto quello che realmente
c’è; per questo motivo, quando si guarda la foto dopo averla scattata, ci
accorgiamo (ormai troppo tardi) dei fili della luce, dei segnali stradali, delle
persone estranee sullo sfondo che al momento dello scatto avevamo sì visto

ma non percepito a livello intellettivo. Anche se, fino ad un certo punto, questi
elementi possono essere eliminati dalla foto usando gimp, la conseguenza è
in genere il peggioramento della qualità dell’immagine.

Regola numero tre: la composizione delle linee e dei colori deve essere

gradevole. Ogni foto è percorsa da linee lungo le quali i particolari che la
compongono vanno naturalmente a disporsi; queste linee guidano l’occhio
dello spettatore attraverso la foto, contribuendo all’effetto estetico di bel
lezza complessiva. Per esempio, più linee che convergano verso un punto
particolare attraggono irresistibilmente l’occhio verso quella posizione: sarà
quindi naturale che lì si trovi ciò che ha stimolato l’attenzione del fotografo e
che per lui è il soggetto principale.

Regola numero quattro: usa le linee ed i punti forti dell’inquadratura.
Se dividiamo con delle linee ideali il fotogramma in tre parti uguali (sia in
orizzontale che in verticale), quelle linee si chiamano linee forti e le loro
intersezioni punti forti del fotogramma; l’occhio umano percepisce come più
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Figura 1.2: a sinistra, le linee ed i punti forti del fotogramma; a destra, oasi
naturalistica di Marano Lagunare (96mm, ISO 200, 1/125s, f/10).

gradevoli ed equilibrate le foto in cui le linee importanti (ad esempio la linea
dell’orizzonte) ed i punti importanti (il soggetto od il suo occhio, una macchia
di colore) si trovano in quelle posizioni1. Come esempio, nella figura 1.2
troviamo a sinistra le divisioni ideali del fotogramma; ed a destra uno scatto
in cui le linee avvolgenti che guidano dal basso verso l’alto a destra l’occhio
di chi guarda si sviluppano lungo le due linee forti orizzontali e finiscono nel
punto “B” mentre una delle papere è nel punto “2”.

Regola numero cinque: cura la messa a fuoco. Il soggetto principale
deve essere tutto a fuoco; se è una persona, metti a fuoco esattamente
sull’occhio. Usa la profondità di campo in modo da utilizzare lo sfocato per
separare i piani dell’immagine: in un paesaggio con figura in primo piano, una
sfocatura più o meno pronunciata del panorama da profondità all’immagine
e fa risaltare il vero soggetto; ancora di più, in una macro, l’uso appropriato
della profondità di campo può isolare il soggetto (fiore o insetto) contro
uno sfondo confuso (foglie, prato, rami). Nella figura 1.3 lo sfocato isola il
soggetto sia dallo sfondo che dalle foglie in primo piano, e da profondità alla
scena.

Incidentalmente, la foto 1.3 non segue la regola delle linee e dei punti forti:
il soggetto è assolutamente centrale, ma l’occhio viene attratto dalle linee
delle foglie in primo piano ed il cervello si concentra solo sulla zona che esse
delimitano, piuttosto che sull’intera foto; al primo sguardo lo sfondo non
viene nemmeno percepito, per cui privilegiare le linee forti della foto intera

non ha molto senso. Chiaramente questo ragionamento è troppo complicato

1Più o meno. . . In realtà una divisione delle figure rettangolari che soddisfi al meglio il
senso estetico di chi guarda dovrebbe essere effettuata secondo la sezione aurea, ovvero
secondo le frazioni 0.38 e 0.62 di larghezza ed altezza (mentre la regola dei terzi qui
enunciata corrisponde a 0.33 e 0.66). In gimp, effettuando selezioni rettangolari, è possibile
scegliere di mettere in evidenza le posizioni che corrispondono alla divisione in tre parti
uguali (Rule of thirds) o secondo la sezione aurea (Golden section).
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Figura 1.3: uso della profondità di campo (208mm, ISO 400, 1/125s, f/7).

per essere fatto a livello conscio; è l’istinto del fotografo che lo segue invece
a livello inconscio, e che guida la composizione dell’immagine.

Regola numero sei: concentrati su quello che ti interessa. Se è un volto,
fagli riempire l’intera inquadratura; se il soggetto è più alto che largo, non
tenere la macchina fotografica in orizzontale ma in verticale (non “landscape”,
ma “portrait”). Attenzione anche a che nessuna parte del soggetto principale
esca dall’inquadratura!

Regola numero sette: se fotografi una persona, abbassati: quando l’inqua
dratura è dall’alto verso il basso, si schiaccia il soggetto contro il terreno;
se invece è dal basso verso l’alto, lo si slancia e gli si da risalto. Invece, se

fotografi edifici (o alberi o, in genere, soggetti con molte linee verticali), tieni

la macchina fotografica ben orizzontale per evitare quelle linee cadenti di cui
parleremo nel capitolo 2.3.

1.2 Gli istogrammi

Nella mia macchina fotografica c’è un tastino contrassegnato dalla scritta
Info; premendolo, compaiono sul display informazioni varie sullo scatto ed
un istogramma: da quest’ultimo si può giudicare la qualità dell’esposizione
della foto. Lo stesso istogramma si può visualizzare in gimp con il menù
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Figura 1.4: una foto (250mm, ISO 800, 1/160s, f/16) ed il suo istogramma.

Windows → Dockable Dialogs → Histogram (e modificare con il menù Colors

→ Curves, ma di questo parleremo più avanti); un esempio è in figura 1.4.
In questo istogramma, in ascissa viene riportata la luminosità dei pixels

che compongono la foto2; e, in ordinata, l’altezza del grafico è proporzionale
al numero di pixels che hanno la corrispondente luminosità. Il valore minimo
dell’ascissa corrisponde a pixels completamente neri, ed il massimo a pixels
completamente bianchi.

Come conseguenza, se l’istogramma non raggiunge, ad esempio, l’estre
mità sinistra della scala, vuol dire che nella foto mancano del tutto i neri
completi: o, in altre parole, che la foto è sovraesposta. Di converso, se l’i
stogramma non raggiunge l’estremità destra della scala, questo significa che
l’immagine è sottoesposta: sono assenti i bianchi puri. Come regola, una
foto ben esposta ha un istogramma regolare di altezza abbastanza costante
ovunque, e che raggiunge entrambi gli estremi dell’asse della ascisse.

In alto, nella finestra, compare la scelta Channel: Value; essa può essere
cambiata in modo da mostrare l’istogramma dei livelli, in ogni pixel, di uno
dei tre colori fondamentali (rosso, verde e blu3). In questo modo l’asse delle
ascisse esprime una scala che va dall’assenza completa del colore selezionato
(a sinistra) alla presenza dello stesso colore alla massima “intensità” (a destra):
e così, usando gli stessi criteri che abbiamo esposto per la luminosità, si può
mettere in evidenza la presenza di una dominante colorata nella foto.

2La scala va da 0 a 255, e non ha alcuna relazione col numero di bits che corrispondono
ad ogni pixel; il formato Canon RAW usa 12 o 14 bits per pixel.

3Oppure tutti e tre assieme, ma usando tre colori differenti.
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1.3 Acquisizione di immagini RAW

Figura 1.5: una foto in formato Canon RAW letta da ufraw.

Il formato Canon RAW è una maniera di archiviare le immagini, nella
memoria della macchina fotografica, che consente di comprendere nel file
corrispondente tutte le informazioni provenienti dai singoli pixels del sensore;
in alternativa, è possibile archiviare le stesse fotografie in formato JPEG: ma
in questo modo (che consente di risparmiare spazio sulla scheda di memoria
diminuendo la dimensione dei files) una parte dei dati acquisiti dal sensore
va però persa.

Se in gimp proviamo ad aprire una immagine in formato RAW (un file
con estensione .CR2), viene richiamato un programma di conversione da
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quel formato a quello nativo di gimp che si chiama ufraw4, e compare la
schermata di figura 1.5: la parte destra della finestra contiene la foto, mentre
quella di sinistra è occupata da istogrammi e controlli. I due istogrammi
mostrano le intensità di rosso, verde e blu nell’immagine: superiormente ci
sono i valori dei dati RAW assieme a delle curve che descrivono graficamente
le trasformazioni ad essi applicate per ottenere l’immagine di destra — le cui
intensità di rosso, verde e blu sono rappresentate nell’istogramma in basso.

Figura 1.6: i controlli di ufraw; dei tabs è stato scelto il secondo (“curve
base”).

I controlli consistono (andando dall’alto verso il basso; questa parte
della finestra è visibile in figura 1.6) nella riga dei pulsanti per il controllo
e la compensazione dell’esposizione, seguita da una sequenza di 6 tabs;
scegliendo uno di essi è possibile correggere altre caratteristiche cromatiche:
nell’ordine (da sinistra a destra) ci sono il bilanciamento dei bianchi, la curva
base, la gestione dei colori, le correzioni di luminosità e saturazione, i crop e
le rotazioni, ed infine la visione dei commenti Exif .

4Devono però essere istallati il programma ufraw ed il plugin ufrawgimp; ufraw può
essere richiamato anche come programma indipendente da gimp, ed usato per convertire
le immagini salvate come RAW in altri formati grafici come JPEG o TIFF.



8 Capitolo 1  Preliminari

Io, quando apro una foto salvata in RAW, effettuo le seguenti operazioni
(nell’ordine)5:

Bilanciamento dei bianchi (primo tab): qui si può variare la tonalità dell’im
magine scegliendone la temperatura di colore; o manualmente usando
gli sliders Temperature e Green, o impostando dei valori predefiniti
che sono: la regolazione scelta dalla macchina fotografica (Camera WB);
la regolazione calcolata automaticamente dal programma stesso (Auto

WB); o sei situazioni di luce standard che consistono in: illuminazione
da lampadine ad incandescenza (Tungsten — che corrisponde ad una
temperatura di colore di 3187 K), luce diurna (Daylight, 4954 K), luce al
neon (Fluorescent, 3831 K), ombra in giornata di sole (Shade, 6438 K),
flash (Flash, 5979 K) e tempo nuvoloso (Cloudy, 5638 K).

La maniera migliore di procedere consiste nell’osservare come ci appare
l’immagine scegliendo prima Auto WB e poi Camera WB, ed eventual
mente anche la selezione che corrisponde meglio alla situazione di
scatto (ombra, nuvoloso, . . . ), e scegliere una tra queste modalità; pren
der nota dei numeri che appaiono nelle finestre degli sliders; ed infine
spostare questi ultimi attorno a quei valori, procedendo per entrambi
lentamente e da sinistra verso destra6. Gli sliders permettono di sce
gliere la temperatura di colore cambiandone i valori sull’asse blugiallo
(quello Temperature) o su quello verdemagenta (Green).

Al di sotto sono possibili cinque scelte per l’algoritmo di decodifica
da RAW a JPEG: AHD, VNG, VNG a quattro colori, PPG, bilineare; è
preferibile usare il default (AHD).

Lo slider etichettato Threshold serve a regolare la soglia per la diminu
zione del rumore digitale: qualora esso sia presente (foto ad alti ISO), lo
si può usare per eliminarlo sfocando l’immagine; ma è preferibile farlo
invece con gimp, come verrà più avanti descritto nel capitolo 3.4.

Curva base (secondo tab): qui sarebbe possibile operare selettivamente sul
l’intensità delle ombre e delle luci; ma anche queste sono operazioni che
preferisco fare in gimp (con il menù Colors → Curves, come vedremo
più avanti).

Gestione dei colori (terzo tab): comincio col deselezionare la scelta Use co

lor matrix, che aumenta in modo per me sgradevole la saturazione dei
colori; poi prendo nota dei valori degli sliders Gamma e Linearity, e li

5Per il significato dei termini (ad esempio temperatura di colore) si può fare riferimento
a Wikipedia o alla documentazione di ufraw.

6Io uso, per queste regolazioni fini, la ruotina del mouse.
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sposto lentamente nell’intorno della posizione scelta dal programma
fino ad ottenere la tonalità migliore.

Luminosità e saturazione (quarto tab): anche qui sposto leggermente lo sli
der Saturation attorno al valore iniziale, cercando di migliorare l’imma
gine.

Crop e rotazioni (quinto tab): non faccio nulla (è preferibile usare gimp).

Exif (sesto tab): sono visualizzati i principali commenti Exif ; non c’è nulla
da fare.

Compensazione dell’esposizione: questa è l’ultima cosa che ci rimane. Se
l’immagine è sottoesposta (o sopraesposta), possiamo schiarirla (o
scurirla) spostando verso destra (o sinistra) il cursore; il valore della
variazione di esposizione (espressa in stop) si legge nella finestrella.
Dei quattro pulsanti, l’ultimo (le frecce) riporta l’impostazione al va
lore di zero; ma le operazioni precedentemente effettuate con i vari
tabs potrebbero aver spostato il valore scelto dal programma per la
compensazione dell’esposizione dallo zero iniziale ad un altro valore.

Degli altri pulsanti, il primo (la lampadina) serve a stabilire come, di
minuendo l’esposizione, devono essere trattate le parti in luce: ci sono
tre possibilità7; il secondo pulsante (la scacchiera) regola invece il
trattamento delle parti in ombra conseguente ad un aumento dell’espo
sizione; infine, il terzo bottone (gli ingranaggi) calcola automaticamente
un valore di correzione dell’esposizione.

Si prende intanto nota del numero che descrive la posizione dello slider,
poi lo si sposta lentamente a sinistra e a destra; quando la luminosità
della foto è soddisfacente, si provano le tre posizioni del primo pulsante
(se il numero è negativo), o le due posizioni del secondo pulsante (se è
positivo), e si sceglie la migliore.

A questo punto si clicca su OK in basso a destra, e la foto viene caricata
dentro a gimp.

7Per i dettagli sul funzionamento di questo bottone e del seguente, si veda il manuale di
ufraw.
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Modifiche geometriche

2.1 Crop

Questa è un’operazione facile da effettuare: si sceglie nel Toolbox il Rectan

gle Select Tool (se si vuole, si può cliccare sull’opzione Highlight per scurire
la zona non selezionata dell’immagine); si effettua la selezione con il mouse;
e, per finire, si usa il menù Image → Crop to Selection. Un’alternativa consiste
nell’usare il Crop Tool che, oltre a permetterci di effettuare la selezione, taglia
direttamente la parte esterna (premendo il tasto Enter).

È meglio evitare di isolare una piccola porzione di immagine per poi
ingrandirla allo spasimo, perché la qualità della foto peggiorerebbe sensibil
mente. . . Dove è invece necessario usare il crop (oltre che per eliminare pali,
fili ed in genere elementi estranei e di disturbo che rimangono nelle parti
periferiche) è in fase di stampa: se sappiamo che il formato della carta sarà
10×15 o 30×40, è inutile lasciare nell’immagine delle parti che non verranno
stampate e (peggio!) delegare al fotografo la scelta di cosa tagliare — basta
usare il Fixed: Aspect ratio per la selezione.

2.1.1 Crop 100%

Con questo termine si intende un particolare ritagliato dall’immagine
senza ridimensionarla: infatti, quando una foto viene mostrata con dimen
sioni differenti da quelle originali (normalmente la si rimpicciolisce), ogni
pixel rappresentato corrisponde a parecchi pixels dell’immagine originale; ed
insomma quello che ci appare dipende non solo da quel che c’è nella foto ma

11
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Figura 2.1: Padova, Prato della Valle; extender 1.4× con 200mm, ISO 200,
1/800s, f/9: la foto originale ed un crop 100%.
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anche dalle azioni del software di visualizzazione. Un crop al 100% (in cui
ogni pixel proviene da uno ed un solo pixel dell’immagine originale) elimina
il contributo del software ed è quindi adatto per approfondire la resa di una
macchina o di un obiettivo, o per paragonare due obiettivi tra loro.

Come esempio, si veda la foto nella figura 2.1 in alto: è stata scattata con
un extender Canon EF 1.4× II accoppiato ad uno zoom Canon EF 70200 mm
f/4 L IS USM usato alla massima focale; con il crop 100% (in basso) si può
verificare che l’uso dell’extender non compromette né la nitidezza dell’im
magine né la precisione dell’autofocus. Per ricavarlo, prima si visualizza la
foto senza ridimensionarla selezionando il menù View → Zoom → 1:1; e poi
si ritaglia un particolare opportuno (qui un quadrato di 8 cm di lato) con uno
dei metodi appena esposti.

2.2 Rotazioni

Poche cose danno fastidio, in una fotografia, più dell’immagine “storta”
dovuta al fatto che la macchina non è stata tenuta bene parallela al terreno al
momento dello scatto: nella figura 2.2 c’è un chiaro esempio, in cui la linea che
marca il confine cielo–mare è visibilmente inclinata rispetto all’orizzontale;
e, nell’altra figura 2.3, vediamo poi il risultato della correzione usata per
eliminare questo difetto.

Per ritoccare l’immagine, nella finestra principale (Toolbox) di gimp si
seleziona il Rotate Tool; tra le varie opzioni presenti, è opportuno usare
Transform: Layer , Direction: Corrective (Backward), e Preview: Image+Grid

(come si può vedere nella metà sinistra della figura 2.4). Usando dei click&drag
è possibile sia spostare il centro della rotazione (ma in questo caso è inutile)
che ruotare la griglia; quando le linee orizzontali di quest’ultima sono ben
allineate con la linea d’orizzonte dell’immagine, si clicca su Rotate nella
finestra ausiliaria (in basso a destra, sempre in figura 2.4).

Tutto questo, però, porta alcune parti dell’immagine originale al di fuori
della cornice rettangolare della foto; e, nello stesso tempo, porta all’interno
della foto punti in origine esterni alla cornice che lo delimitava, punti che
corrispondono alle zone quadrettate vicine agli angoli nella parte sinistra
della figura 2.5: zone che sono trasparenti e che si trovano in un nuovo layer
creato appositamente. Bisogna ora eliminare queste parti trasparenti: nella
finestra principale si clicca sul Rectangle Select Tool; si seleziona quanto più
possibile dell’immagine originale (vedi la parte destra della figura 2.5); dai
menù si sceglie prima Image → Crop to Selection, poi Image → Flatten Image

ed infine File → Save.
Personalmente preferisco eseguire manualmente queste ultime fasi, in
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Figura 2.2: il porto di Marano Lagunare; foto originale (18mm, ISO 400,
1/400s, f/13).

Figura 2.3: la foto 2.2 dopo il ritocco con gimp.
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Figura 2.4: a sinistra, la finestra principale di gimp; a destra, la sequenza che
illustra come si inizia a correggere la figura 2.2.
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Figura 2.5: a sinistra, la foto ruotata; a destra, una selezione che elimina le
“zone morte” degli angoli.

modo che la selezione rettangolare contenga esattamente le parti dell’imma
gine ruotata che voglio io; è possibile però lasciare a gimp la responsabilità
di queste operazioni, scegliendo Clipping: Crop to Result tra le opzioni del
Rotate Tool. In questo modo gimp lascia selezionata una regione rettangolare
che contiene la massima parte possibile della foto; basta poi eseguire Image

→ Autocrop Image seguito da Image → Flatten Image e salvare.

2.3 Linee cadenti

Quando l’obiettivo non è tenuto esattamente orizzontale, le linee verticali
(invece di essere parallele tra loro) convergono verso un punto di fuga che
non coincide con il centro della foto (linee cadenti); come esempio, guardate
gli alberi dell’immagine in alto a sinistra in figura 2.6. Lì l’effetto è voluto,
ed esaltato dalla corta focale usata; ma, se lo si volesse però eliminare (per
ottenere alla fine l’immagine in alto a destra nella stessa figura), bisognerebbe
richiamare il Perspective Tool di gimp con le stesse opzioni (Transform: Layer ,
Direction: Corrective (Backward), Preview: Image+Grid) che abbiamo usato
per il Rotate Tool.

Sempre nella figura 2.6 possiamo vedere, in basso a sinistra, come appare
l’immagine a questo punto; si continua trascinando con dei click&drag i vertici
della griglia, in modo da rendere le linee di quest’ultima, per quanto possibile,
parallele alle linee verticali della foto. Prima di questa operazione è opportuno
selezionare, nel menù View, l’opzione Snap to Canvas Edges: in questo modo,
i lati della griglia che stiamo modificano tenderanno ad “appiccicarsi” ai bordi
dell’immagine; senza insomma includere in essa piccole porzioni dell’esterno
(che risulterebbero trasparenti). Quando si è soddisfatti, infine, si sceglie
Transform nella finestra ausiliaria.
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Figura 2.6: in alto: a sinistra la foto originale, presa nei boschi del monte
Amiata (10mm, ISO 400, 1/125s, f/7); e, a destra, la foto modificata. In basso:
la finestra di gimp all’inizio ed alla fine del lavoro con il Perspective Tool.
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Attenzione che, correggendo le linee cadenti, parte della foto originale
(quella esterna alla griglia quando si clicca su Transform) viene persa; che una
zona dell’immagine (in questo caso quella in alto) viene espansa, perdendo
in qualità; e che gli oggetti fotografati, nella trasformazione, cambiano le
loro proporzioni in larghezza e/o in altezza a seconda di dove si trovano.
Sarebbe molto meglio evitare di modificare l’immagine prendendosi un attimo
di tempo prima dello scatto, in modo da curare l’inclinazione della macchina
fotografica. . .

2.4 Distorsioni della lente

L’uso di focali molto corte (grandangoli) può introdurre nell’immagine,
oltre alle linee cadenti, anche altri tipi di distorsione. Ad esempio, nella foto
in alto a sinistra in figura 2.7 (fatta con un obiettivo di lunghezza focale
10mm), si vede chiaramente che le linee verticali non sono solo inclinate:
sono anche deformate, così da apparire non più come rette ma come archi di
cerchio. Per correggere queste distorsioni (che pure hanno un loro fascino e,
almeno ai miei occhi, non danno molto fastidio) si può usare il menù Filters

→ Distorts → Lens Distortion: il corrispondente filtro ci presenta una finestra
come quella che vediamo, sempre nella figura 2.7, in alto a destra; ed il suo
scopo è quello di introdurre nell’immagine delle distorsioni — solo che noi ce
ne serviremo selezionandone di esattamente opposte a quelle già prodotte
dall’obiettivo, in modo da annullarle. Ecco il significato dei sei cursori che il
programma ci presenta (dall’alto verso il basso):

Main: introduce distorsioni di sfericità (quelle, in parole povere, che abbiamo
appena illustrato come caratteristiche dei grandangoli); valori positivi
diminuiscono la concavità dell’immagine, mentre valori negativi la
aumentano.

Edge: introduce una ulteriore distorsione di sfericità, ma limitata ai quattro
angoli dell’immagine.

Zoom: aumenta (o diminuisce) le dimensioni dell’immagine.

Brighten: cambia la luminosità delle zone ai bordi dell’immagine, in modo
da introdurre (o da annullare) un effetto di vignettatura1.

1Col nome di vignettatura si indica la diminuzione della luminosità dell’immagine sui
bordi: questa è prodotta o intrinsecamente da un sistema di lenti (tipicamente dalle corte
focali); o, per errore del fotografo, quando venga montato un filtro o un paraluce le cui
estremità siano visibili ai margini dell’inquadratura.



2.4  Distorsioni della lente 19

Figura 2.7: in alto: a sinistra la foto originale, scattata nel porto di Essaouira
in Marocco (10mm, ISO 800, 1/800s, f/16); e, a destra, la finestra del filtro
Lens Distortion. In basso: a sinistra l’effetto del filtro; e, a destra, un crop di
questa immagine che ne riporta la forma a rettangolare.
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Xshift: sposta l’immagine verso destra o sinistra, introducendo (o eliminan
do) nel contempo la tipica distorsione prodotta da una lente disassata.

Yshift: la stessa cosa, ma disassando verso l’alto o verso il basso.

Mentre si gioca con i cursori, l’effetto prodotto dal filtro viene mostrato
nella finestra di preview. Io ho scelto, per correggere la foto in esame, i valori
{50,10,10,−10,0,0} per i sei parametri rispettivamente; così da produrre
l’immagine in basso a sinistra nella figura 2.7. Il passo finale consiste nel
ritagliare un’immagine rettangolare a partire da questa: usando prima il
Rectangle Select Tool per definire una opportuna selezione, e poi terminando
con Image → Crop to Selection).



Capitolo 3

Modifiche cromatiche

3.1 Bianco e nero

Non è difficile convertire una foto a colori in una in bianco e nero, ma
raramente è utile: il fascino delle “vere” foto in bianco e nero è dato non solo
dal colore (o, piuttosto, dalla sua mancanza) quanto da altri fattori, come
ad esempio la grana; questa manca totalmente nelle foto digitali: può essere
simulata, come vedremo più avanti, ma in genere con scarsi risultati.

Comunque sia, per risultare gradevole in bianco e nero una foto deve
avere le seguenti caratteristiche: deve basarsi sui contorni degli oggetti e sulle
linee dominanti che li congiungono e non sui colori o sui contrasti cromatici;
deve contenere sia nero quasi completo che bianco quasi completo, che però
devono occupare una piccola zona dell’immagine1; deve contenere infine

Figura 3.1: a sinistra la foto originale, scattata al lago di Barcis (100mm, ISO
200, 1/400s, f/11); e, a destra, la stessa foto convertita in bianco e nero.

21
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l’intera gamma dei grigi, risultando tanto più bella quanto più questa gamma
è ricca. Come esempio si può vedere la figura 3.1, dove l’interesse è dato dalle
linee curve del lungolago e delle panchine (queste ultime enfatizzate dalle
ombre) spezzate dal profilo verticale del lampione (forse un poco troppo
centrale); nell’originale, i colori impediscono all’occhio di concentrarsi solo
sulle linee.

Per la conversione si può usare il menù Colors → Desaturate; ci sono tre
opzioni, che usano differenti formule per convertire il colore di un pixel in
livelli di grigio a seconda della sua lightness, della luminosità o del livello
medio dei valori RGB. Non esiste una regola fissa; conviene esaminare i
risultati delle tre opzioni alternandoli (cliccando uno dopo l’altro sui tre
bottoni di selezione), e scegliere quella che sembra dare, per quella foto, i
migliori risultati. Per la foto della figura 3.1 si è usata l’opzione Average;
invece, per la figura 3.2 di cui parleremo nel capitolo 3.1.1, si è scelta quella
Lightness.

Un altro modo, più complicato ma che lascia un maggiore controllo sul
risultato, è quello di scegliere dai menù Colors → Components → Channel Mi

xer; si selezionano sia l’opzione Monochrome che quella Preserve Luminosity,
e poi si aggiustano i valori {R,G, B} a piacere (un buon punto di partenza è la
terna {50,40,10}) fino a che non si è soddisfatti.

3.1.1 Aggiunta di grana simulata

Si parte da un’immagine già convertita in bianco e nero; la procedura da
seguire è lunga e complicata ma, visto che in seguito operazioni analoghe
saranno necessarie per altri scopi, vediamo di scendere un poco in dettaglio
ora sui singoli passi da compiere. Le varie fasi descritte corrispondono alle
scelte ed alle opzioni illustrate in figura 3.3 ed in figura 3.4.

1. Per prima cosa, nella Toolbox di gimp si clicca sul foreground color

(normalmente nero), e lo si cambia in un grigio neutro (R = 128, G =
128, B = 128).

2. Si apre il Layers Dialog, scegliendo dal menù Windows → Dockable

Dialogs → Layers; si clicca poi sull’iconcina in basso a sinistra per
creare un nuovo layer. Nella finestra che si aprirà, si sceglie per il nuovo
layer l’opzione Layer Fill Type: Foreground Color , ed il nome “Grana”
al posto del default “New Layer”. Ovviamente quest’ultima cosa non
è strettamente necessaria, ma è sempre meglio dare ai vari layers dei

1Larghe zone di nero completo o di bianco completo, che insomma non lascino scorgere
tracce di particolari al proprio interno, sono esteticamente sgradevoli.
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Figura 3.2: in alto: a sinistra la foto originale (55mm, ISO 400, 1/500s, f/16);,
a destra, la stessa in bianco e nero. In basso: a sinistra, in bianco e nero con
grana simulata; a destra, in seppia.
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Figura 3.3: le prime fasi seguite per produrre la versione con grana simulata
dall’originale in figura 3.2.
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Figura 3.4: le fasi finali seguite per produrre la versione con grana simulata
dall’originale in figura 3.2.

nomi che abbiano un significato chiaro — altrimenti, riprendendo in
mano l’immagine dopo qualche tempo, si rischierebbe di confondersi.

3. Fatto questo, la finestra dell’immagine mostrerà un’immagine del nuovo
layer, ovviamente grigia uniforme; sempre nel Layers Dialog scegliamo
però l’opzione Mode: Overlay, che ci consente di vedere assieme i due
layers sovrapposti.

4. Si seleziona il layer “Grana” (dovrebbe già essere selezionato); si sceglie
dai menù Filters → Noise → HSV Noise. Si portano i parametri Hue e
Saturation a 0, Value a 100 e si lascia Holdness a 2; si aggiusta la qualità
della pseudograna (visibile nella finestra di Preview), cambiando per
primo Value e (solo dopo) Holdness, fino a che non si è soddisfatti:
infine si clicca su OK. Se l’effetto risultante non piace, si usa Edit →

Undo seguito da Filters → ReShow; e si continua a cambiare i parametri
Value e Holdness fino a che non si è soddisfatti.

Se la grana fosse troppo netta, si può a questo punto applicare Filters →

Blur → Gaussian Blur al layer; conviene scegliere un Blur Radius piccolo,
valori da 1 a 3 dovrebbero andare bene.

5. Ora, nelle vere foto in bianco e nero, la grana si vede soprattutto
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nelle tonalità intermedie e molto meno nei bianchi e nei neri puri:
per realizzare questo effetto riprendiamo il Layers Dialog e, dopo un
rightclick sul layer “Grana”, scegliamo Add Layer Mask e White (Full

Opacity).

Un Layer Mask è un layer ausiliario speciale, che andrà riempito di
bianchi, di neri e di tonalità grige intermedie; il suo scopo è quello di
filtrare selettivamente il contenuto del layer cui è associato (la grana si
mulata): in modo da trasmetterlo tutto (molta grana) in corrispondenza
dei bianchi; bloccandolo tutto (nessuna grana) in corrispondenza dei
neri; e mostrandosi parzialmente trasparente altrove, in proporzione
al livello di grigio. Il passo successivo da compiere per raggiungere il
nostro scopo, quindi, consisterà nel modificare il Layer Mask in modo
che contenga nero in corrispondenza dei bianchi e dei neri puri dell’im
magine originale, e bianco invece dove in quell’immagine vi siano delle
tonalità intermedie di grigio.

6. Nel Layers Dialog clicchiamo sul Background Layer ; scegliamo, dai
menù della finestra principale con l’immagine, prima Select → All e poi
Edit → Copy; nel Layers Dialog clicchiamo l’icona del Layer Mask (il
quadratino bianco accanto al nome “Grana”); scegliamo dai menù Edit

→ Paste e, ancora nel Layers Dialog, clicchiamo sull’ancoretta. In questo
modo abbiamo prima creato un nuovo layer con una copia dell’imma
gine originale; e, ancorandolo al Layer Mask, abbiamo effettivamente
riversato la suddetta copia in quest’ultimo.

7. A questo punto dovrebbe ancora essere selezionato il Layer Mask. Si
sceglie dai menù Colors → Curves; si clicca nel centro della linea retta
per aggiungervi un control point a metà; infine, con dei click&drag, si
porta il control point finale dall’angolo in alto a destra fino a quello in
basso a destra e si alza quello centrale fino a tre quarti dell’altezza.

8. Ora, se l’effetto è soddisfacente, si sceglie Image → Flatten Image e
si salva; altrimenti, con una serie di Edit → Undo si torna indietro e
si modifica qualcosa nella procedura seguita. Il risultato è in basso a
sinistra in figura 3.2,

3.1.2 Immagine monocroma virata in seppia

La voce Colors → Colorize del menù consente di trasformare l’immagine
iniziale in una che sia stata prima convertita in bianco e nero e poi “vista”
attraverso un filtro colorato virtuale, il cui colore può essere scelto a piacere;
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se la qualità della conversione in bianco e nero non ci soddisfa, è meglio
effettuarla “a mano”, come detto all’inizio del capitolo 3.1, prima di scegliere
questa opzione per virare il colore. Un buon punto di partenza per la terna
{H,S, L} è {30,70,30} (un esempio è in basso a destra in figura 3.2).

Un altro metodo consiste nello scegliere il menù Filters → Decor → Old

Photo con le opzioni Sepia e Work on Copy (quest’ultima consente di non
alterare l’immagine originale); ma i risultati in genere mi paiono più scadenti
che col metodo precedente.

3.2 Occhi rossi

Gli occhi rossi sono causati dal riflesso, sulla retina del soggetto fotografa
to, dei flash delle macchine economiche (che, a causa delle ridotte dimensioni,
sono troppo vicini all’obiettivo): per eliminarli, si ingrandisce la parte che
comprende gli occhi; si seleziona poi una zona ristretta che li comprenda; e
si usa infine il menù Filters → Enhance → Red Eye Removal. Per selezionare le
sole pupille, è possibile cominciare con una soltanto di esse; e pensare poi a
selezionare l’altra, ma tenendo premuto il tasto Shift — in questo modo, la
seconda selezione si aggiunge alla prima.

3.3 Foto troppo contrastate o dettagliate

Quando si usa il flash, le ombre e le luci possono essere troppo crude e
far diventare la foto troppo contrastata. Il tutto si corregge facilmente con il
menù Colors → BrightnessContrast, agendo prima sul contrasto e poi sulla
luminosità; ricordate che, se cliccate su una delle finestrelle contenenti il va
lore numerico poste accanto agli sliders Brightness e Contrast, una pressione
sui tasti Page Up e Page Down aumenta o diminuisce rispettivamente questi
valori di un fattore 10.

Inoltre, alcuni obiettivi (i macro tra tutti) sono costruiti per rendere esat
tamente il minimo dettaglio e, se usati per ritratti, mettono in risalto rughe
e difetti della pelle in modo antiestetico; in questo caso si può tentare di
sfocare leggermente l’immagine col menù Filters → Blur → Gaussian Blur

oppure col menù Filters → Blur → Blur.

3.3.1 Le maschere di contrasto

Se una foto è troppo contrastata, contiene generalmente sia parti molto
luminose che altre molto oscure; e, se decidiamo di stamparla, vedremo
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Figura 3.5: in alto: a sinistra la foto originale (il fiume Elba a Blankenese; Sony
DSCS90, 6mm, ISO 80, 1/800s, f/5.6) e, a destra, la stessa immagine dopo
aver applicato la maschera di contrasto. In basso, la maschera di contrasto
prima e dopo l’applicazione del gaussian blur .
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che la qualità dell’immagine su carta è decisamente peggiore della qualità
dell’immagine che avevamo studiato al computer. Il motivo sta nel fatto che
i display (sia CRT che LCD) sono in grado di mostrare sfumature di colore
in quantità estremamente superiore rispetto alla carta fotografica e, come
risultato, nella stampa si perderanno molti dettagli: specialmente nelle parti
più luminose ed in quelle più oscure.

Un modo di attenuare il contrasto in vista della stampa (oltre all’uso
appena descritto di Colors → BrightnessContrast) e, contemporaneamente,
mettere in evidenza i dettagli sia delle zone chiare che di quelle oscure, è
il metodo della maschera di contrasto; è illustrato nella figura 3.5 dove, in
alto, vediamo l’immagine prima (a sinistra) e dopo l’elaborazione (a destra).
Si opera così:

1. Si sceglie dai menù Windows → Dockable Dialogs → Layers; dopo un
rightclick sull’unico layer, di nome Background, si sceglie l’opzione
Duplicate Layer .

2. Si clicca due volte sul nuovo layer, che si chiama Background copy, e se
ne cambia il nome in Maschera di contrasto2.

3. Si vira il layer della maschera di contrasto in bianco e nero usando il
menù Colors → Desaturate (qui abbiamo scelto l’opzione Average); e,
subito dopo, si muta il layer in “negativo”, col menù Colors → Invert (il
risultato è visibile in basso a sinistra nella figura 3.5).

4. Si “sfoca” la maschera di contrasto usando il menù Filters → Blur →

Gaussian Blur ed impostando un valore alto nelle finestre dei raggi
orizzontale e verticale: il default è 5, un valore tra 20 e 30 dovrebbe
essere adatto (per questa foto io ho usato 30); il risultato è in basso a
destra, sempre in figura 3.5.

5. Si torna sul Layers Dialog, e si sceglie Mode: Overlay; si gioca con il
cursore Opacity fino ad avere un risultato soddisfacente (per questa
foto io lo ho lasciato su 100).

6. Si sceglie dai menù Image → Flatten Image; e, infine, si salva.

Qual’è il motivo di queste operazioni? Alla fine del passo 3 la maschera di
contrasto contiene delle parti scure in corrispondenza delle zone luminose
dell’immagine originale, e viceversa; quindi, sovrapponendo le due immagini
nel passo 5, l’effetto risultante è quello di scurire le parti chiare e schiarire le

2Abbiamo già spiegato, nel capitolo 3.1.1, la ragione per cui è preferibile cambiare il
nome del nuovo layer.
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parti scure. La sfocatura del passo 4 serve a rendere l’effetto meno netto e
più progressivo.

Una tecnica complementare a questa (e che serve quindi ad aumentare il
contrasto) verrà illustrata più avanti nel capitolo 3.6, dopo aver parlato degli
interventi sulla luminosità ed il colore mediante gli opportuni strumenti di
gimp.

3.4 Rimozione del rumore digitale

Se si è impostata una sensibilità troppo elevata (un numero ISO troppo
grande) è possibile che la foto mostri del rumore digitale: delle piccole
zone, nelle parti più scure, dove compaiono dei colori che non esistevano
nella scena originale. Per cercare di eliminare questi difetti si può usare il
menù Filters → Blur → Selective Gaussian Blur: il risultato della sua azione
è una leggera sfocatura di quelle sole parti dell’immagine che abbiano un
contrasto inferiore ad un valore di soglia scelto dall’utente, con conseguente
diminuzione del rumore digitale.

Selezionando nella finestra di preview le zone rumorose della nostra foto,
è abbastanza facile scegliere un valore del Delta (la differenza tra pixels
adiacenti che rappresenta la soglia di contrasto di cui parlavamo) che limiti
l’azione del filtro alle sole parti dell’immagine che vogliamo modificare;
l’altro parametro (il Blur Radius) regola l’entità dell’azione di sfocatura e
ammorbidimento applicati alle aree sotto la soglia di contrasto.

3.5 Problemi di esposizione

Se una foto è sovraesposta (troppo chiara, mancano i neri puri) o sottoe
sposta (troppo scura, mancano i bianchi puri) è possibile correggerla in vari
modi. Ricordatevi però sempre la regola di esporre per le luci riprendendo
una scena con parti sia molto scure che molto chiare contemporaneamen
te: il motivo è che, mentre è relativamente semplice recuperare in fase di
postproduzione le parti sottoesposte, quelle sovraesposte (o, come si dice in
gergo, bruciate) sono irrimediabilmente perse.

1. Nei casi semplici basta scegliere il menù Colors → BrightnessContrast

e regolare opportunamente i due parametri relativi.

2. Con il menù Colors → Levels, scegliendo Channel: Value, l’istogramma
(come abbiamo visto nel capitolo 1.2) mostra quanti pixels nell’imma
gine hanno una determinata luminosità. Abbiamo già detto in quel
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capitolo che una foto bene esposta dovrebbe avere un istogramma abba
stanza uniforme su tutto l’intervallo dei valori; che foto sottoesposte lo
hanno asimmetrico e spostato verso sinistra (verso le basse luminosità);
mentre foto sovraesposte lo hanno al contrario spostato verso destra.

I tre triangolini sotto l’istogramma mostrano i valori del “nero”, del
“grigio medio” (o gamma) e del “bianco”: nel senso che tutti i pixels
corrispondenti ad intensità non superiori a quello di sinistra vengono
resi come nero completo; quelli con intensità non minori di quello di
destra vengono resi come bianco completo; e quello di mezzo indica
pixels che vengono resi con una luminosità esattamente intermedia
tra nero puro e bianco puro. I due contagocce permettono di spostare
il primo e l’ultimo dei tre triangolini3 puntando pixels dell’immagine
che dovrebbero corrispondere al nero ed al bianco puro; il bottone
Auto, come vedremo meglio più avanti nel capitolo 3.7, cerca di fare un
aggiustamento automatico di questi tre livelli ma separatamente per le

componenti rossa, verde e blu della foto e senza toccare il canale delle

intensità.

Se una foto è, ad esempio, sovraesposta, manca la parte più a sinistra
dell’istogramma; spostando a destra il valore del “nero” fino a dove
l’istogramma comincia e, solo dopo, giocando col valore del “grigio
medio” per aggiustare il bilancio tra ombre e luci, in genere si riesce
a correggere l’immagine. Per le foto sottoesposte si segue la stessa
procedura, solo agendo inizialmente sul valore del “bianco”; ricordate
anche che spostare verso sinistra il cursore del “grigio medio” schiarisce
l’immagine, mentre spostarlo verso destra la scurisce.

Un esempio è in figura 3.6: i neri ed i bianchi in realtà sono abbastanza
soddisfacenti, e si è agito solo sul bilancio tra ombre e luci.

Figura 3.6: una foto sottoesposta (gioiello al museo Dalì di Figueres: 55 mm,
ISO 200, 1/30s, f/5.6); le modifiche scelte col menù Colors → Levels; ed il
risultato.

3Oppure, più semplicemente, si trascinano i triangolini con un click&drag del mouse.
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3. Con il menù Colors→ Curves si può effettuare una correzione più mirata
cambiando la forma della curva di rendering dei pixels: in ascissa c’è
sempre la luminosità; alzando l’ordinata della curva si schiariscono
tutti i punti dell’immagine che ad essa corrispondono (e, abbassandola,
li si scuriscono).

Figura 3.7: panorama di Tossa de Mar (41mm, ISO 400, 1/400s, f/14) prima e
dopo l’elaborazione con, in centro, la finestra del menù Colors → Curves.

Nella figura 3.7 vediamo come, sempre usando il menù Colors → Curves,
si è cercato di affrontare una situazione leggermente differente: nella foto
originale ci sono sia zone sottoesposte (le ombre in primo piano, che andreb
bero schiarite) che zone sovraesposte (il cielo, che è “bruciato”). La curva di
resa dell’intensità dei pixels è stata modificata come si vede nel centro della
figura, cercando di lasciare inalterato il rendering dei mezzi toni (quelli su cui
l’occhio umano si concentra e che “vede” di preferenza) e modificando solo
quello che riguarda le alte ombre e le alte luci. È da ricordare che aumentare
la pendenza della curva nella regione centrale dei mezzi toni accrescerebbe
anche il contrasto dell’immagine; e che diminuirne la pendenza abbasserebbe
il contrasto4.

3.6 Sovrapposizione dell’immagine sfocata

Questa tecnica è complementare a quella vista prima nel capitolo 3.3.1
sulle maschere di contrasto: si tratta sempre di sovrapporre alla foto originale

4Questa stessa foto continuerà ad essere elaborata nel capitolo 4.4.3
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un secondo layer da essa stessa ricavato, ma questa volta non tanto per
attenuare il contrasto quanto invece per aumentarlo. Si applica quindi ad
immagini piatte; e, come effetto collaterale, vedremo che inoltre aumenta
anche la saturazione dei colori (e questo, in una immagine piatta, in genere
non guasta).

Figura 3.8: a sinistra l’immagine originale (Sony DSCS90, 10.3mm, ISO 100,
1/50s, f/3.5, flash); a destra quella elaborata con la tecnica della sovrap

posizione dell’immagine sfocata; e, in centro, il layer aggiuntivo usato per
realizzarla.

La sovrapposizione dell’immagine sfocata è una tecnica che riesce utile
anche quando si vuole addolcire la foto, come ad esempio suggerito nel
capitolo 3.3 per i ritratti con il flash; questo se l’applicazione (lì menzionata)
del menù Filters → Blur → Gaussian Blur dovesse creare un effetto troppo
deciso e sgradevole. I passi da seguire sono:

1. Si apre il Layers Dialog; si duplica il Background layer e gli si attribui
sce un nome tipo Sfocato per ricordarne la funzione; infine si sceglie
Mode: Overlay per vedere assieme i due layers sovrapposti. A que
sto punto ogni zona colorata viene “vista due volte”, una per layer,
con un conseguente aumento (in genere sgradevole) della saturazione
dell’immagine.

2. Lasciando selezionato il layer Sfocato, si richiama il menù Colors →

Levels; e si agisce sul solo riferimento del “grigio medio” (quello cen
trale), spostandolo verso sinistra in modo da schiarire l’immagine. Se
il risultato non apparisse soddisfacente, si esegue un Edit → Undo e si
cerca una posizione migliore del cursore. Io ho usato, per l’immagine
della figura 3.8, un valore 3.
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3. Sempre lasciando selezionato il layer Sfocato, si richiama il menù Filters

→ Blur → Gaussian Blur e si sceglie un valore elevato (tra 10 e 30) di
entrambi i raggi (Blur radius; il default è 5): sempre per l’immagine in
figura 3.8, ho usato 25. Al solito, se l’effetto non fosse soddisfacente si
esegue Edit → Undo e si cambiano i numeri; nella parte centrale della
figura 3.8 si vede come appare a questo punto il solo layer Sfocato (non

come appaiono entrambi i layers sovrapposti).

4. Si torna sul Layers Dialog, e si sperimenta con il cursore Opacity fino
ad avere un risultato soddisfacente (io lo ho messo su 80); si sceglie
Image → Flatten Image; e, infine, si salva.

3.7 Dominanti colorate

Se l’immagine ha una dominante colorata, si possono usare alcuni dei
metodi che abbiamo citato per i difetti di esposizione: ovvero i due menù
Colors→ Levels e Colors→ Curves. È infatti possibile, al loro interno, scegliere
di operare singolarmente sui valori {R,G, B} del rosso, verde e blu dei pixels
(invece che sulla loro luminosità).

Nella finestra di controllo di Colors → Levels, come già detto, c’è un
bottone Auto che cerca di farlo in maniera automatica e che potrebbe dare
risultati soddisfacenti: cliccando su questo bottone, gimp (separatamente
per i canali rosso, verde e blu) cerca di localizzare l’inizio e la fine dell’isto
gramma dei pixels, spostando poi sopra gli estremi individuati i triangolini di
“nero completo” e di “piena intensità di colore” (ed aggiustando nello stesso
tempo adeguatamente il triangolino del “colore medio”). Se il risultato appa
risse cromaticamente strano, si può tentare di recuperarlo controllando ed,
eventualmente, correggendo le azioni di gimp nei tre canali {R,G, B} (il pro
gramma potrebbe avere individuato malamente le estremità degli istogrammi:
questo in genere avviene quando sono molto bassi e vicini allo zero) e, solo
alla fine, intervenendo anche sul canale delle intensità (Channel: Value).

Nel menù Colors ci sono altre due voci dedicate a questi problemi di
correzione delle dominanti cromatiche, che però sono meno potenti (anche
se più semplici) dei due menù citati sopra; la prima, Colors → Color Balance,
permette di ridurre o esaltare la presenza di una delle componenti croma
tiche fondamentali (rosso, verde, blu; ciano, magenta e giallo) esaltando o
riducendo contemporaneamente la componente complementare.

La seconda voce, Colors → HueSaturation, presenta un requester in cui
compaiono ancora le sei componenti cromatiche fondamentali: si sceglie il
colore della dominante (o, se si seleziona Master , tutti i colori sono affetti; ma
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non è questo ciò che ci interessa qui). Lo slider Overlap permette, se spostato
verso destra, di estendere il cambiamento anche a colori più o meno vicini,
a seconda del suo valore, a quello principale; cambiamento che si effettua
agendo sugli sliders Hue, Saturation e Value.

È chiaro anche che il nostro scopo potrebbe essere quello di esaltare un
colore: quando il primo piano si stacca contro il cielo azzurro, aumentare
la saturazione del blu mette in evidenza lo sfondo e fa risaltare meglio il
soggetto principale; o, se il soggetto stesso fosse un insetto colorato contro
il verde dell’erba, aumentare la saturazione del verde servirebbe allo stesso
scopo.

Figura 3.9: foto di Filippo Picinni prelevata dal sito del Canon Club Italia,
http://www.canonclubitalia.com (Canon EOS 40D, Canon 300mm f/4 L
IS USM, ISO 100, 1/8000s, f/4).

A volte è il caso, invece, di inserire nella nostra foto una dominante
colorata: è il caso della figura 3.9, dove si è operato5 prima con Colors →

Levels (esaminato nel capitolo 3.5) in modo da rendere totalmente nero quanto
appare in primo piano; e poi con Colors → Colorize (che abbiamo incontrato
nel capitolo 3.1.2) per introdurre una dominante giallina che contrastasse col
primo piano, in modo da farlo risaltare e nello stesso tempo conferire alla
composizione una sensazione di profondità.

5In realtà l’autore ha elaborato l’immagine con Adobe Photoshop; ho tradotto le
operazioni da lui presumibilmente effettuate nel linguaggio di gimp.
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3.8 Rimozione di piccoli difetti

Quando facciamo il ritratto di una persona in primissimo piano, è possibile
che nella foto vengano messi in evidenza difetti della pelle che da lontano
non si notano, come nei o brufoli; o, più banalmente, se il nostro sensore è
sporco e nella foto c’è una grossa estensione di cielo, su di essa compariranno
in evidenza le caratteristiche fastidiose macchie dovute alla polvere.

È possibile rimuovere questi difetti, se si ha pazienza; il manuale di gimp

consiglia di usare l’Healing Tool, ma io mi ci trovo male e preferisco, invece,
usare il Clone Tool.

Per prima cosa si ingrandisce di molto la foto nella zona da ritoccare;
poi si seleziona un pennello appropriato, un Circle o un Fuzzy Circle di
dimensioni adatte a quelle del difetto da eliminare. Si cerca, nell’intorno di
quest’ultimo, un’altra zona di pelle (o di cielo) avente luminosità e tonalità di
colore giuste per rimpiazzare la zona da ritoccare; la si preleva con Ctrlleft
click: e con uno o più leftclick la si duplica al di sopra della parte incriminata,
per ricoprirla.

Come ho detto, ci vogliono molta pazienza e molti Edit → Undo prima di
ottenere risultati soddisfacenti: ma, una volta presa la mano, si può anche
riuscire a cancellare una persona che si è infilata nella nostra inquadratura, e
la cui presenza in un paesaggio deserto ci da fastidio.

3.9 Immagine sfocata o mossa

Purtroppo c’è ben poco da fare. Si può provare a richiamare il menù
Filters → Enhance → Unsharp Mask usando i valori di default per Radius

e Amount (aumentando i relativi valori l’effetto aumenta, ed il risultato è
visibile in tempo reale nella finestrella di preview); ma in generale il migliora
mento dell’immagine che si ottiene è abbastanza scarso. Dove invece questo
menù funziona abbastanza decentemente è nel ridurre il micromosso nelle
macrofotografie.

Esaminiamo un po’ più in dettaglio il funzionamento del filtro Unsharp

Mask: sostanzialmente gimp cerca di individuare all’interno dell’immagine le
zone di confine in cui avviene una rapida transizione tra luminosità basse ed
alte; e, nell’intorno di queste zone, diminuisce ulteriormente la luminosità
della parte scura e la aumenta nella parte chiara, in modo da accrescere (solo
localmente) il contrasto. I tre parametri del requester controllano:

• Radius, per che distanza dalla “linea di confine” la variazione di lumi
nosità deve essere applicata;
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• Amount, l’entità di questa variazione;

• Threshold, il minimo numero di pixels entro i quali una differenza
sostanziale di luminosità viene interpretata come “confine”.

Figura 3.10: a sinistra, una foto sfocata (54mm, ISO 200, 1/30s, f/2.8); in
centro, il layer Value dopo la scomposizione; a destra, l’immagine ricomposta
dopo l’applicazione a questo layer del filtro Unsharp Mask.

L’occhio umano però non reagisce allo stesso modo a tutti i colori della
foto: ad esempio, tra due pixels l’uno verde puro e l’altro blu puro dello
stesso valore numerico, il primo è “visto” molto più intenso del secondo;
quindi, basandosi soltanto sui valori {R,G, B} dei pixels, è possibile che il
filtro Unsharp Mask introduca delle alterazioni cromatiche sgradevoli. Se
questo accade, ecco come bisogna procedere (l’esempio riguarda la foto a
sinistra in figura 3.10, chiaramente sfocata):

1. Si seleziona, dai menù di gimp, Colors → Components → Decompose;
nel requester si sceglie Color model: HSV e ci si assicura che Decompose

to layers sia attivato, prima di cliccare su OK. In questo modo i valori
della sola luminosità vengono correttamente immessi in un layer a
parte, e su di quello si applicherà poi il filtro Unsharp Mask.

2. Si apre il Layers Dialog col menù Windows→ Dockable Dialogs→ Layers,
e si seleziona il layer Value; conviene poi rendere invisibili (cliccando
sull’occhio accanto al loro nome) gli altri due layers Hue e Saturation, in
modo da vedere il solo layer che ci interessa (appunto Value): il risultato
è al centro, sempre in figura 3.10.
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3. Si applica il filtro Unsharp Mask a questo layer, curando opportunamen
te la scelta dei parametri Radius, Amount e Threshold.

4. Si seleziona, dai menù, Colors → Components → Compose; dopo aver
scelto Color model: HSV , si clicca su OK.

A destra, sempre in figura 3.10, c’è il risultato finale: una immagine sempre
leggermente sfocata, ma più accettabile.

3.10 Correzioni automatiche

gimp ha tutta una serie di menù dedicati all’aggiustamento automatico
delle foto; ma, secondo me, la gestione dell’immagine compiuta da questi
menù non funziona molto bene e conviene sempre intervenire manualmente
(secondo le linee guida illustrate nei capitoli precedenti). Comunque, per
completezza, queste voci (col loro significato) sono:

• Colors → Auto → Equalize: aggiusta la luminosità in modo che l’isto
gramma Channel: Value (che appartiene al menù Colors → Levels e di
cui abbiamo parlato nel capitolo 3.5) sia quanto più possibile piatto; in
altre parole, il numero di pixels che hanno un certo valore di luminosità
verrà reso più o meno lo stesso (indipendentemente dal colore).

• Colors → Auto → White Balance: gimp individua i punti che, nei tre
istogrammi {R,G, B} (vedi capitolo 3.7), si trovano alle due estremità e
che comincino ad essere sensibilmente diversi da zero; e porta i due
triangolini del “nero completo” e della “piena intensità di colore” ai
limiti della zona non scartata (aggiustando nello stesso tempo adegua
tamente il triangolino del “colore medio”). Dovrebbe avere lo stesso
effetto del menù Colors → Levels seguito dalla selezione del bottone
Auto (vedi, in proposito, il capitolo 3.7).

• Colors → Auto → Color Enhance: aumenta la saturazione dei colori
senza alterare altrimenti i pixels; in sostanza dovrebbe rendere i colori
più vividi, ma senza toccare bianchi e neri.

• Colors → Auto → Normalize: aggiusta l’intera immagine cercando per
prima cosa il pixel meno luminoso e quello più luminoso; poi, cambian
do il primo in nero puro ed il secondo in bianco puro; e successivamente
aggiustando in proporzione la sola luminosità di tutti gli altri pixels.
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• Colors→ Auto→ Stretch Contrast: compie la stessa operazione di Colors

→ Auto → Normalize, ma separatamente per i tre canali {R,G, B}; in
sostanza cerca di rendere più brillanti le parti brillanti della foto, e più
oscure le parti oscure.

• Colors → Auto → Stretch HSV: compie la stessa operazione di Colors →

Auto → Stretch Contrast, ma agendo nello spazio dei colori {H,S, V}
invece che in quello {R,G, B}





Capitolo 4

Come modificare solo una parte di

una foto

Figura 4.1: a sinistra la foto originale (55mm, ISO 125, 1/500s, f/5.6); e, a
destra, quella elaborata.

La tecnica che abbiamo usato nel capitolo 3.1.1 può essere impiegata per
modificare solo una parte di una fotografia e lasciare inalterato il rimanente:
in sostanza si tratta di preparare due layers, uno contenente l’immagine
originale ed uno contenente quella elaborata con gimp; e nell’associare a
quest’ultimo layer un layer mask che renda visibile l’immagine elaborata (che
si sovrappone a quella originale) solo dove vogliamo noi.

Per spiegarci meglio, facciamo vedere come si può modificare una foto
trasformandola in bianco e nero ma lasciando alcune zone colorate, così
come si vede nella figura 4.1. I passi da seguire sono:

1. Si apre il Layer Dialog con Windows → Dockable Dialogs → Layers e,
cliccando su una delle icone in basso, si duplica il background layer;

41
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Figura 4.2: due fasi del procedimento usato per produrre l’immagine in
figura 4.1.

con un rightclick sul layer duplicato, si seleziona Edit Layer Attributes

e si cambia il suo nome in BW.

2. Lasciando selezionato il layer BW, lo si cambia in bianco e nero usando
uno dei metodi descritti nel capitolo 3.1: qui si è utilizzato il menù
Colors → Desaturate scegliendo l’opzione Average.

3. Dopo un rightclick su BW nel Layers Dialog, si sceglie Add Layer Mask

con l’opzione White (full opacity); a questo punto il Layers Dialog diventa
come illustrato a sinistra in figura 4.2.

4. Si seleziona il layer mask, cliccando sul quadratino bianco (a destra,
sulla linea del layer BW nel Layers Dialog; vedi la figura 4.2). Si controlla
che il foreground ed il background color siano bianco e nero rispettiva
mente; nel Toolbox si seleziona il Pencil Tool e si sceglie un pennello
adatto (ad esempio un Circle Brush di diametro mediogrande).

5. Si ingrandisce di molto (200 ÷ 300%) l’immagine, e si ricopre di nero
tutta la parte in cui si vuole lasciare, inalterata, l’immagine originale
a colori: in questo caso, la rosa in primo piano. Si procede con calma
e con piccoli tratti; se si sbava al di fuori dalla zona desiderata, si
corregge usando il bianco per cancellare la zona di nero in eccesso nel
layer mask. A destra, nella figura 4.2, si vede come appare l’immagine
dopo un poco di lavoro.

Fate attenzione a non lasciare piccoli spazi scoperti; si può usare, per
controllare, il Select by Color Tool: si seleziona, nel layer mask, la zona
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dipinta di nero e la si esamina attentamente per vedere se per caso al
suo interno siano rimaste piccole “isole” di bianco.

6. Si richiama Image → Flatten Image e si salva.

4.1 Come cambiare il colore degli occhi

Figura 4.3: la foto 1.3 ritoccata col metodo del capitolo 4.1.

Un metodo un poco più semplice (non ci serviremo infatti di due layers
ma di uno solo) è stato usato per ritoccare la foto della figura 1.3 e produrre
quella della figura 4.3. Per prima cosa si è convertita l’immagine in bianco e
nero; poi si è selezionata la zona degli occhi; ed infine è stato richiamato il
menù Colors → Colorize (il cui effetto, che abbiamo già descritto nel capito
lo 3.1.2, è ristretto alla sola zona selezionata), applicato con valori opportuni
(i parametri del verde usato qui sono H = 120, S = 100 e L = 30).

La difficoltà sta solo nell’effettuare la selezione correttamente: per questo
si deve ingrandire molto la zona degli occhi, poi si clicca sul Free Select Tool e
si cerca di contornare, dapprima rozzamente, la zona che interessa. Si curano
poi i dettagli effettuando delle altre selezioni mentre si tiene premuto o il
tasto Shift (in questo caso la selezione attuale si aggiungerà alla precedente)
o quello Ctrl (la selezione attuale verrà sottratta dalla precedente). Alla fine,
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se giudichiamo che i contorni della zona selezionata non siano regolari, si
può usare il menù Select → Feather per “diffonderli” e sfumarli: il default di
5 pixels è in genere più che adeguato.

A seconda del tipo di zona da selezionare può essere opportuno usare,
invece del Free Select Tool, qualche altro strumento di gimp: come il Fore

ground Select Tool (se la zona della selezione voluta si staglia nettamente
sullo sfondo) o lo Scissors Select Tool (se il confine della zona da selezionare
vede anche il passaggio da un colore ad un altro).

4.2 Come sbiancare i denti

Figura 4.4: un esempio di sbiancatura dei denti: un particolare in cui si vede
la selezione dell’area su cui operare (a sinistra), e l’immagine ritoccata (a
destra).

Si agisce esattamente come nel capitolo 4.1, selezionando però i denti del
soggetto in primo piano; poi si richiama il menù Colors → HueSaturation

per cambiare il colore della selezione. Un buon punto di partenza è Primary:

Master , H = 0, L = 33, S = −70; un esempio è in figura 4.4.

4.3 Come schiarire le ombre

Per foto che contengano sia zone di ombre molto scure che altre di luci
molto chiare, abbiamo già ricordato (nel capitolo 3.5) la regola che dice di
esporre per le luci lasciando le ombre sottoesposte; rimane poi il problema
di schiarire quelle ombre in fase di postproduzione, che nel capitolo citato
abbiamo già affrontato. Una possibile elaborazione alternativa dell’immagine
con gimp si può fare nel modo seguente:
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Figura 4.5: un esempio di schiaritura delle ombre: in alto, la foto originale
(a sinistra) e quella ritoccata (a destra); in basso, il layer mask del layer ND
prima (a sinistra) e dopo (a destra) il gaussian blur .
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1. Si rende visibile il Layers Dialog con il menù Windows → Dockable

Dialogs → Layers.

2. Cliccando su una delle piccole icone visibili in basso nel Layers Dialog

si duplica il background layer; e, dopo un double click sul nome del
layer appena creato, lo si cambia in ND1.

3. Dopo un rightclick sul layer ND nel Layers Dialog, si sceglie Add

Layer Mask; nella finestra che compare, poi, si selezionano sia la voce
Grayscale copy of layer che quella Invert mask.

4. Il layer mask di ND è rimasto selezionato; si clicca sull’immagine (la
piccola finestra nel layer ND alla sinistra del layer mask), e ad essa
si applicano le trasformazioni appropriate in modo che la parte del
l’immagine che contiene le ombre (la parte “brutta”, insomma) diventi
accettabile; come abbiamo detto, si possono usare Colors → Brightness

Contrast, oppure Colors → Levels, oppure Colors → Curves. Qui si è
scelto Colors → BrightnessContrast, aumentando la luminosità di 50
ed il contrasto di 15.

5. Si rende invisibile il background layer cliccando, nel Layers Dialog,
sull’occhio; si clicca sul rettangolino del layer mask, in modo da selezio
narlo; e, dopo un rightclick sul layer ND, si seleziona Show Layer Mask

in modo che soltanto il layer mask sia visibile.

6. Dai menù, si sceglie Color → Threshold; si sposta il cursore in modo
che le zone rimaste in bianco del layer mask corrispondano alle parti
dell’immagine schiarita che si vogliono rendere visibili (qui abbiamo
lasciato il default di 127).

7. La transizione da zone visibili a zone invisibili del layer ND è però
troppo netta: dai menù si seleziona Filters → Blur → Gaussian Blur, e si
sceglie un valore elevato dei Blur Radius (qui si è usato 50).

8. Dopo un rightclick (nel Layers Dialog) sul layer ND, si deseleziona Show

Layer Mask; e si rende in questo modo di nuovo visibile la sovrappo
sizione dei due layers (ND e background) mediata dal layer mask. Si
giudica l’effetto complessivo e, se necessario, si torna indietro con uno

1ND sta per Neutral Density, che è la sigla dei filtri grigi neutri che assorbono luminosità
senza modificare le tonalità dei colori. Come al solito, il cambio di nome non sarebbe
strettamente necessario: ma è meglio che la funzione di ognuno dei layers sia immediata
mente comprensibile dal nome; specialmente riprendendo l’immagine dopo qualche tempo,
quando si sono già dimenticati i dettagli di quanto fatto in precedenza.
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o più Edit → Undo, e si modifica qualcuna delle nostre azioni. Quando
si è soddisfatti, si seleziona Image → Flatten Image e si salva.

Un esempio è in figura 4.5; in realtà le ombre, nella foto originale, non
danno molto fastidio: ma si è ugualmente ritoccata l’immagine secondo il
metodo su esposto.

4.4 Come ricostruire uno sfondo

4.4.1 Sfondo di colore uniforme

Figura 4.6: in alto: a sinistra la foto originale, scattata in un ristorante (48mm,
ISO 200, 1/60s, f/3.5, flash); a destra il soggetto principale selezionato con lo
Scissors Select Tool. In basso: il risultato finale.

La foto in alto a sinistra nella figura 4.6 è abbastanza decente, ma le
necessità dello scatto (eseguito in un luogo pubblico) hanno imposto uno
sfondo dispersivo che confonde l’immagine e disorienta chi la guarda; in
questo caso si è preferito annerirlo uniformemente, in modo da lasciar visibile
il solo soggetto principale. Si sono eseguite queste operazioni:



48 Capitolo 4  Come modificare solo una parte di una foto

• Si è selezionato il solo primo piano; si può procedere con diversi stru
menti, ma abbiamo optato per lo Scissors Select Tool. Si richiede, per
il tool, l’opzione Feather edges; e poi, con una serie di leftclick, si
segue il contorno della parte da isolare: inserendo control points più
distanti quando non ci sono angoli nel contorno, o più vicini se questo è
irregolare. Alla fine, si clicca nuovamente sul primo punto per chiudere
il contorno; e, se il soggetto fosse mal delineato, o si aggiungono altri
control points oppure si spostano opportunamente quelli esistenti. Per
trasformare infine il contorno in una selezione, serve un leftclick al
suo interno oppure si preme il tasto Enter (il risultato è in figura 4.6 in
alto a destra).

• Si sceglie dai menù Select → Invert per invertire la selezione, spostando
la allo sfondo.

• Si controlla che il foreground color sia il nero; si sceglie il Bucket Fill

Tool scegliendo l’opzione Fill whole selection; e si clicca sullo sfondo
selezionato, per annerirlo.

• Si è completata la postproduzione applicando una maschera di contra
sto come descritto nel capitolo 3.3.1; e, visto che la linea di contatto
tra lo sfondo da una parte ed il vestito ed i capelli scuri dall’altra era
innaturale e disturbava, con il Blur/Sharpen Tool in modalità Blur ed
un Circle Brush si sono sfocati leggermente quei contorni.

4.4.2 Sfondo sfocato

Un altro modo di far risaltare il soggetto in primo piano è quello di sfocare
lo sfondo; per capire meglio guardiamo le due immagini, iniziale e finale, in
alto nella figura 4.7. Per passare dall’una all’altra, quello che si è fatto è stato:

1. Si è aperto il Layers Dialog (col menù Windows → Dockable Dialogs →

Layers); con un click su una delle piccole icone in basso si è duplicato
il layer “Background”; con un doppio click sul nome del nuovo layer
(Background Copy) lo si è cambiato in “Sfocato”; ed infine, cliccando
sulla piccola icona in basso con una freccia, lo si è spostato sotto il layer
“Background”.

2. Sempre nel Layers Dialog, cliccando sull’occhio nella riga del layer
“Background” rendiamolo invisibile, e concentriamoci sull’altro. Richia
miamo il menù Filters → Blur → Gaussian Blur, e scegliamo un Blur

Radius grande sia in orizzontale che in verticale (io ho usato 50 per
entrambi); l’immagine diventa come in figura 4.7 in basso a sinistra.
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Figura 4.7: in alto: a sinistra la foto originale (200mm, ISO 200, 1/640s, f/7);
e, a destra, quella elaborata. In basso: a sinistra il layer Sfocato alla fine del
passo 2 delle istruzioni; e, a destra, la selezione del soggetto invertita.
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3. Rendiamo nuovamente visibile il layer “Background” cliccando, ancora
nel Layers Dialog, sul suo occhio; e dopo un rightclick, sempre sul
layer “Background”, scegliamo Add Layer Mask con l’opzione White (full

opacity); il layer mask rimane selezionato.

4. Con lo stesso metodo che abbiamo usato nel capitolo 4.4.1, selezionia
mo il solo soggetto principale; e, col menù Select → Invert, invertiamo
la selezione spostandola sullo sfondo (vedi la figura 4.7 in basso a
destra). Per finire, scegliamo dal menù Select → Feather per sfumare la
selezione, usando il valore di default di 5 pixels.

5. Assicuriamoci che, nel Toolbox, il Foreground Color sia il nero; sele
zioniamo il Bucket Fill Tool ed attiviamo l’opzione Fill whole selection;
cliccando in un punto dello sfondo, che abbiamo selezionato nella
finestra principale, riempiamolo di nero.

6. A questo punto il lavoro è ultimato: il layer mask che abbiamo così
costruito lascia vedere lo sfocato del layer sottostante nello sfondo e
l’immagine originale, a fuoco, dove c’è il soggetto. Scegliamo dai menù
Image → Flatten Image e salviamo.

4.4.3 Come ricostruire il cielo

Figura 4.8: fine dell’elaborazione della foto di figura 3.7. Da sinistra a destra:
l’immagine originale e le due fasi della costruzione del layer mask.

Riprendiamo in esame la foto della figura 3.7, che possiamo rivedere
(a sinistra) in figura 4.8; anche dopo averne schiarito le ombre, l’immagine
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Figura 4.9: da sinistra a destra: in alto, le due versioni del layer Cielo; in
basso, le corrispondenti immagini finali.
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è tuttora insoddisfacente perché il cielo è sovraesposto, bianco e privo di
dettagli: in una sola parola, bruciato. Con una variante della tecnica usata nel
capitolo 4.4.1 per rendere nero lo sfondo della foto 4.6, è possibile rendere
più naturale il cielo di questa foto: però, invece di ricoprire lo sfondo con una
mano di vernice nera, ci disegneremo sopra un cielo “finto” ma accettabile.

La maniera migliore di farlo consiste nell’usare un’immagine del cielo scat
tata in un’altra occasione; ma un buon risultato si ottiene anche utilizzando
un semplice gradiente tra due diverse sfumature di azzurro. È chiaro che solo
la zona occupata dal cielo nell’immagine originale deve essere modificata; e
quindi dovremo servirci di un opportuno layer mask. Ecco come si procede:

• Apriamo l’immagine originale; scegliamo dal menù Windows → Doc

kable Dialogs → Layers; cliccando su una delle piccole icone in basso
duplichiamo il layer originale (Background) e, dopo un double click sul
nuovo layer, cambiamone il nome in Cielo.

• Scegliamo dai menù Colors → Threshold; l’effetto è quello di convertire
tutti i pixels di intensità inferiore ad un valore di soglia scelto dall’utente
in nero puro, e tutti gli altri in bianco puro. Spostando il triangolino
nero alla base dell’istogramma cerchiamo una soglia per la quale la
totalità del cielo rimanga ancora bianca (io ho usato per la mia immagine
il valore 214): cliccando su OK, l’immagine acquista l’aspetto di quella
che si vede al centro in figura 4.8.

• Non basta ancora, perché sono rimaste nel layer mask delle zone bian
che in parti che non appartengono al cielo: dopo aver scelto il Rectangle

Select Tool, selezioniamo tutta la parte del layer Cielo che rimane al di
sotto della linea dell’orizzonte; scegliamo il Bucket Fill Tool e clicchiamo
(tenendo premuto il tasto Shift per riempire col foreground color, nero,
l’intera selezione) in quella zona: l’immagine diventerà come quella a
destra nella figura 4.8.

• A questo punto il layer mask è completo: facciamo un rightclick su Cielo

nel Layers Dialog, scegliamo Add Layer Mask, selezioniamo Grayscale

copy of layer ed infine clicchiamo su OK.

• Se non abbiamo una buona foto di cielo, impostiamo come foreground
e background colors due opportune tonalità di azzurro: buone scelte di
partenza sono R = 187, G = 219 e B = 255 (più scuro) o R = 230, G =
239 e B = 255 (più chiaro); io ho usato quest’ultima per il foreground e
bianco puro per il background color.

Si apre Windows → Dockable Dialogs → Gradients e si seleziona FG to

BG (RGB); si clicca sul rettangolino del layer Cielo (non sul layer mask!)
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nel Layers Dialog; si annulla una eventuale selezione; si sceglie il Blend

Tool (Mode: Normal, Shape: Linear) e si riempie il layer di un gradiente
(che apparirebbe come in alto a sinistra nella figura 4.9 qualora venisse
disabilitato il layer mask).

• Se invece abbiamo una buona foto di cielo (magari con qualche nuvolet
ta), apriamola e riversiamola nel layer Cielo (come si vede a destra in
alto nella figura 4.9). Per questo occorre:

– Selezionare una parte opportuna dell’immagine e, se necessario,
ridimensionarla: io, direttamente nelle opzioni del Rectangle Se

lect Tool, ho impostato Fixed: Size 1664:1050 (i numeri sono le
dimensioni della zona del cielo nel layer mask). Alla fine, eseguire
un Edit → Copy.

– Selezionare il layer Cielo (non il layer mask!) nel Layers Dialog;
dopo un rightclick su Cielo, sempre nel Layers Dialog, disabilitare
il layer mask; eseguire sull’immagine Select → All, Edit → Fill with

BG color e Select → None per riempire Cielo di bianco (non è
necessario, ma fa meno confusione :).

– Scegliere Edit → Paste e muovere in alto l’immagine copiata del
cielo; ed infine cliccare sull’ancoretta, sempre nel Layers Dialog.
A questo punto si riabilita anche il layer mask e l’operazione è
completata.

• Si seleziona Image → Flatten Image e si salva; i risultati sono visibili in
basso nella figura 4.9.

4.5 Come drammatizzare un tramonto

A sinistra, nella figura 4.10, è stato fotografato un tramonto: adesso
vedremo come si può fare per esaltarne i colori (magari anche in modo
chiaramente esasperato) per rendere più drammatica l’immagine. I passi
usati per arrivare al risultato finale (a destra in figura 4.12) sono stati i
seguenti:

1. Si clicca sul foreground color e lo si cambia in uno più adatto; nell’e
sempio ho usato un rosso aranciato con componenti {R = 250, G =

138, B = 32}.

2. Si apre il Layers Dialog (Windows → Dockable Dialogs → Layers) e si
clicca (in basso) sulla piccola icona che creerà un nuovo layer, al quale
si darà nome Tramonto.
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Figura 4.10: a sinistra la foto originale (tramonto sul Nilo; Sony DSCS90,
18mm, ISO 80, 1/30s, f/5.2) e, a destra, la finestra del Layers Dialog.

Figura 4.11: a sinistra la curva di correzione del Layer Mask e, a destra,
l’immagine ottenuta.
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Figura 4.12: a sinistra la correzione dei livelli e, a destra, l’immagine finale.

3. Col Bucket Fill Tool si riempie Tramonto (il layer è rimasto selezionato
dopo la sua creazione) con il color rossoarancio prima scelto.

4. Si resetta il foreground color a nero; si apre Windows → Dockable

Dialogs → Gradients e si seleziona FG to BG (RGB). Dopo un rightclick
su Tramonto nel Layers Dialog, si seleziona Add Layer Mask; ed infine,
nel Toolbox, si sceglie il Blend Tool.

5. Sempre nel Layers Dialog, si clicca sul layer mask di Tramonto per
selezionarlo; quindi lo si riempie totalmente, in senso verticale, usando
un gradiente che vada dal nero al bianco (lasciando il nero in basso ed
il bianco in alto). A questo punto il Layers Dialog appare come a destra
in figura 4.10.

6. All’immagine originale adesso è sovrapposto il rossoarancio prescelto,
sfumato dall’alto in basso; si aggiusta il decrescere della sfumatura,
prima usando il menù Colors → Curves (a sinistra in figura 4.11), e solo
dopo aggiustando nel Layers Dialog il cursore Opacity (che abbiamo
portato a 80). Il risultato è a destra, sempre nella figura 4.11.

7. Si sceglie Image → Flatten Image. Adesso, però, alla parte in ombra
dell’immagine si è sovrapposto il rossoarancio che abbiamo scelto,
che lo schiarisce in maniera inaccettabile; per ovviare, con il menù
Colors → Levels (vedi a sinistra in figura 4.12) si aggiustano gli estremi
dell’istogramma — e si arriva al risultato finale.

Aggiungo solo che a me piace di più l’immagine originale di quella elaborata;
tutta questa procedura è solo l’esempio di una tecnica utile.





Capitolo 5

Tecniche speciali

5.1 Effetto Dragan

Andrzej Dragan è un fotografo molto noto, che è solito elaborare grafi
camente le sue immagini (in special modo quelle di ritratti) così da dar loro
un aspetto grafico caratteristico1 identificato dagli appassionati appunto col
nome di effetto Dragan. Qui di seguito vedremo come sia possibile modificare
una foto in modo da conferirle un aspetto simile: premettiamo però che
in rete esistono parecchi tutorials che insegnano tecniche simili, ognuno
in modo diverso, e che il metodo che verrà esposto è una mia personale
interpretazione; inoltre che l’effetto finale non è esasperato, ma può essere
reso più evidente ed incisivo aumentando l’entità delle modifiche descritte
nei vari passi della trasformazione.

Nella figura 5.1, in alto, vediamo l’immagine iniziale e quella finale a fianco
a fianco; per passare dall’una all’altra abbiamo applicato questi passi:

1. Aumentiamo il contrasto usando una maschera:

• Apriamo il Layers Dialog, scegliendo dai menù Windows → Docka

ble Dialogs → Layers.

• Cliccando su una delle piccole icone in basso, duplichiamo il layer
dell’immagine.

• Trasformiamo il nuovo layer in bianco e nero, usando il menù
Colors → Desaturate (noi abbiamo scelto l’opzione Luminosity).

1Per vedere degli esempi, guardate nella sua galleria fotografica online alla URL
http://andrzejdragan.com/ .

57
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Figura 5.1: in alto, a sinistra la foto originale (171mm, ISO 800, 1/250s, f/6.3)
e a destra quella elaborata. In basso: due fasi intermedie del ritocco.
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• Applichiamo una leggera sfocatura con Filters → Blur → Gaussian

Blur (noi abbiamo lasciato i Blur Radius default di 5 pixels).

• Nel Layers Dialog abbiamo poi selezionato Mode: Overlay, ed
infine regolato il cursore Opacity in modo da ottenere un effetto
soddisfacente (noi lo abbiamo lasciato sul 100%).

• Abbiamo concluso fondendo i due layers con Image → Flatten

Image.

2. Oscuriamo i bordi dell’immagine:

• Nel Layers Dialog clicchiamo sulla piccola icona in basso che crea
un nuovo layer; scegliamo l’opzione Layer Fill Type: White.

• Troviamo il centro dell’immagine: richiamando due volte il menù
Image→ Guides→ New Guide (by Percent) creiamo due linee guida,
una orizzontale ed una verticale, a metà (50%) dell’immagine.

• Selezioniamo, nel Toolbox, il Blend Tool; scegliamo l’opzione Gra

dient e clicchiamo sulla freccia alla sua destra, in modo che si vada
dal bianco al nero e non viceversa; infine scegliamo anche Shape:

Radial.

• Selezioniamo le due voci dei menù View → Snap to Guides e View

→ Snap to Canvas Edges.

• Nella finestra dell’immagine, facciamo un click&drag che dal punto
centrale vada alla metà di uno dei lati verticali: vedremo comparire
l’immagine di figura 5.1 in basso a sinistra.

• Cancelliamo le linee guida (Image → Guides → Remove all Guides);
scegliamo poi Mode: Overlay nel Layers Dialog; controlliamo il
cursore Opacity (lasciato al 100%); e concludiamo con Image →

Flatten Image.

3. Rendiamo la tonalità più calda:

• Nel Layers Dialog, clicchiamo prima su una delle piccole icone per
duplicare il layer; scegliamo poi Mode: Soft Light.

• Richiamiamo il menù Colors → Colorize; abbassiamo Hue ad un
valore di circa 20 o 30 (che corrisponde grosso modo ad un rosso
aranciato), ed aumentiamo sia Lightness che Saturation: noi qui
abbiamo modificato i valori di default di {H = 180, L = 50, S = 0}
per passare a quelli {H = 20, L = 75, S = 25}.
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• Il layer superiore, se visto da solo (ad esempio tornando a Mode:

Normal) appare come nella figura 5.1 in basso a destra; controllia
mo che sia selezionato Mode: Soft Light e fondiamo i due layers
con Image → Flatten Image.

• Duplichiamo ancora il layer, e scegliamo questa volta Mode: Hue.

• Dopo aver richiamato il menù Colors → Components → Channel

Mixer, aumentiamo (nell’Output Channel: Red) i rossi ed attenuia
mo i verdi: noi siamo passati dai valori di default di {R = 100, G =
0, B = 0} a quelli {R = 120, G = −20, B = 0}

• Concludiamo ancora con Image → Flatten Image.

4. Rendiamo l’immagine più incisa:

• Selezioniamo il menù Filters → Enhance → Sharpen e, osservando
la parte centrale del volto nella finestra di preview, scegliamo un
opportuno valore di Sharpen: noi abbiamo usato 50 al posto del
default di 10.

A questo punto il procedimento è concluso.

5.2 High Dynamic Range (HDR)

Con il nome di High Dynamic Range, o brevemente HDR, si indica una
tecnica speciale che ci permette di avere foto dall’esposizione equilibrata
in presenza sia di zone con ombre profonde che di zone con alte luci. In
sostanza si tratta di scattare non una sola foto, ma tre: una che sia esposta
“mediamente” ed in cui si distinguano correttamente i mezzi toni; una che
sia, rispetto alla precedente, sottoesposta (ma in modo tale che in essa sia
corretta l’esposizione delle alte luci); ed infine una che sia sovraesposta (ed
in cui siano però correttamente esposte le ombre profonde). Alla fine, con
gimp, si crea una immagine finale costruita componendo assieme tutte e tre le
foto; ma prendendo da ognuna di esse solo la parte che risulta correttamente
esposta (un esempio è in figura 5.2).

Per potere usare l’HDR bisogna rispettare alcuni presupposti; per prima
cosa, le tre foto devono essere esattamente sovrapponibili: e questo implica
quasi necessariamente l’uso del cavalletto. Inoltre, la differenza di esposizio
ne tra le tre foto deve essere tale da rendere correttamente le luci in una, le
ombre nell’altra ed i toni intermedi nella terza. La mia EOS 350D permette2

2Cercate sul manuale AEB, che sta per Auto Exposure Bracketing.
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Figura 5.2: nelle due foto in alto, ed in quella in basso a sinistra, le
tre immagini di partenza; in basso a destra il risultato finale. Le pri
me tre foto sono di Giovanni Brembati, e sono state prelevate dalla URL
http://www.photoresampling.com/hdr.php .
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di scattare una raffica di tre foto con differenza di esposizione tra l’una e
l’altra fino ad un massimo di due stop e selezionabile a incrementi di 1/3
di stop; ma questa differenza deve essere stata correttamente stimata: in
pratica bisogna leggere le indicazioni dell’esposimetro sia per le ombre che
per le luci, e calcolarla giustamente.

Per prima cosa si apre l’immagine con esposizione media; poi si carica in
un nuovo layer l’immagine sottoesposta (ma con le alte luci esposte corretta
mente), e si agisce sul suo layer mask in modo che soltanto la zona delle alte
luci sia visibile, a ricoprire la corrispondente zona della prima immagine:

• Si apre (con File → Open) l’immagine intermedia.

• Si apre (sempre con File → Open) anche l’immagine sottoesposta (che
apparirà in una differente finestra); si seleziona (Select → All) l’intera
foto; e la si copia nella clipboard (Edit → Copy).

• Tornati sulla finestra dell’immagine intermedia, si apre il Layers Dialog

(Windows → Dockable Dialogs → Layers) e si crea un nuovo layer, clic
cando sulla piccola icona in basso a sinistra; come nome useremo Luci,
e sceglieremo la voce Layer Fill Type: Foreground Color . In conseguenza
di queste azioni, nella finestra dell’immagine intermedia apparirà il
nuovo layer, completamente nero.

• Si sceglie il menù Edit → Paste, e si ancora l’immagine copiata dalla
clipboard al nuovo layer cliccando sull’icona con l’ancoretta del Layers

Dialog.

• Sempre nel Layers Dialog, clicchiamo sull’occhio del layer Background

per renderlo invisibile; apparentemente non cambia nulla perché, prima
di creare il layer mask, tutto il layer Luci è visibile e ricopre il layer
Background.

• Dopo un rightclick sul layer Luci, scegliamo Add Layer Mask selezio
nando l’opzione Grayscale copy of layer , e deselezionando quella Invert

Mask.

Il motivo della scelta dell’opzione Grayscale copy of layer è che, per
lasciare visibile la sola zona delle alte luci nel nuovo layer, il suo layer mask
deve contenere bianco nella zona appunto delle luci, come già prima spiegato
nel capitolo 3.1.1; quindi una copia convertita in bianco e nero dell’immagine
originale è un buon punto di partenza. In ogni caso, è opportuno giudicare
l’effetto complessivo cliccando più volte in successione sull’occhio del layer
Background (in modo da renderlo alternativamente visibile ed invisibile); e,
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Figura 5.3: le correzioni applicate al layer mask dell’immagine sottoesposta
(a sinistra) e di quella sovraesposta (a destra).

se necessario, interverremo sul layer mask usando lo strumento Colors →

Curves3 come già spiegato sempre nel capitolo 3.1.1: io ho usato la correzione
visibile a sinistra in figura 5.3.

Ora si ripete la procedura per l’immagine sovraesposta, in cui sono però
correttamente esposte le ombre profonde:

• Si apre (File → Open) l’immagine sovraesposta (che apparirà in una
terza finestra); si seleziona (Select → All) l’intera foto, e la si copia nella
clipboard (Edit → Copy).

• Tornati sul Layers Dialog dell’immagine intermedia, si crea un nuovo
layer e gli si da nome Ombre.

• Si sceglie (nell’immagine intermedia) il menù Edit → Paste; si ancora
l’immagine copiata dalla clipboard al nuovo layer, sempre usando (nel
Layers Dialog) l’iconcina con l’ancora.

• Rendiamo invisibili entrambi i layers Background e Luci (con un click
sugli occhi nel Layers Dialog). Poi, dopo un rightclick sul layer Ombre,

3Ovviamente bisogna prima selezionare il layer mask di Luci, con un click sul quadratino
relativo dentro il Layers Dialog.
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scegliamo Add Layer Mask; e selezioniamo ancora l’opzione Grayscale

copy of layer ma anche, questa volta, quella Invert mask (il trattamento
delle ombre è ovviamente complementare a quello delle luci).

• Giudichiamo, come spiegato in precedenza, l’effetto complessivo; e, se
necessario, aggiustiamo il nuovo layer mask con Colors → Curves (io ho
usato la correzione a destra in figura 5.3).

• Si sceglie il menù Image → Flatten Image e si salva il risultato.



Appendice A

Scripting

gimp ha un proprio linguaggio di scripting; anzi, per essere esatti, usa
per lo scripting un linguaggio di programmazione che si chiama scheme.
scheme è un dialetto del lisp, linguaggio ad alto livello inventato nel 1958
(è, storicamente, il secondo di questa categoria dopo il Fortran) da John
McCarthy; ogni azione conseguente alla scelta da parte dell’utente di uno
dei menù di gimp può anche essere ottenuta, in un programma in scheme,
richiamando una funzione con opportuni parametri: così che per automatiz
zare una sequenza di operazioni da ripetere sempre uguali basta scrivere un
programmino in scheme che contenga i corrispondenti richiami.

Qui di seguito ci sono due scripts che automatizzano le procedure illu
strate nei capitoli 3.3.1 (“Maschere di contrasto”) e 3.6 (“Sovrapposizione
dell’immagine sfocata”); per usarli bisogna

• Creare due files di nome rispettivamente mlocontrastlayer.scm

e mloblurlayer.scm nella directory degli scripts; che per me, ad
esempio, si chiama ~/.gimp2.6/scripts . I files devono ovviamente
contenere il codice listato qui avanti.

• Scegliere dai menù ScriptFu → Contrast → Add Contrast Layer (per la
maschera di contrasto) o ScriptFu → Contrast → Add Blur Layer (per la
sovrapposizione dell’immagine sfocata); il menù ScriptFu comparirà la
prima volta che avvierete gimp dopo aver creato i due files di scripting.

• Scegliere i parametri appropriati e cliccare su OK.

È molto meglio non selezionare la casella Flatten Image nella finestra delle
opzioni; in questo modo i due layers (dell’immagine e della maschera) ri

65
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mangono separati, ed è possibile sia agire sulla maschera con livelli e curve,
sia esaminare l’effetto di differenti scelte (nel Layers Dialog) del parametro
Opacity prima di richiamare manualmente Image → Flatten Image.

A.1 Script per la maschera di contrasto

mlocontrastlayer.scm

1 ; Author: Maurizio Loreti, aka MLO or (HAM) I3NOO

2 ; Work: University of Padova  Department of Physics

3 ; Via F. Marzolo, 8  35131 PADOVA  Italy

4 ; Phone: +39 (049) 8277216 FAX: +39 (049) 8277102

5 ; EMail: Maurizio.Loreti@gmail.com

6 ; WWW: http://www.pd.infn.it/~loreti/mlo.html

7 ;

8 ;

9 ; Scriptfu programs for image handling with GIMP: contrast mask

10 ;

11 ; $Id: mlocontrastlayer.scm,v 1.4 2008/11/16 10:08:22 loreti Exp $

12 ;

13 ;

14 ; myduplicatelayer (borrowed from David Meiklejohn & Harry Phillips)

15 ;

16 (define (myduplicatelayer image layer)

17 (let* ((duplayer (car (gimplayercopy layer 1))))

18 (gimpimageaddlayer image duplayer 0)

19 duplayer))

20 ;

21 ;

22 ;

23 (define (scriptfuMLOcontrastlayer

24 InImage InLayer InRadius InOpacity InFlatten)

25 ; save history

26 (gimpimageundogroupstart InImage)

27 ; duplicate layer

28 (let (

29 (contrast (myduplicatelayer InImage InLayer))

30 )

31 (gimplayersetname contrast "ContrastMask")

32 ; desaturate and invert the new layer

33 (gimpdesaturate contrast)

34 (gimpinvert contrast)

35 ; Gaussian blur on the new layer

36 (plugingauss 1 InImage contrast InRadius InRadius 1)

37 ; set opacity to the preset value, and layer mode to overlay

38 (gimplayersetopacity contrast InOpacity)

39 (gimplayersetmode contrast OVERLAY)

40 ; flatten image?

41 (if (= InFlatten TRUE) (gimpimageflatten InImage))

42 ; finish

43 (gimpimageundogroupend InImage)

44 (gimpdisplaysflush)

45 )

46 )

47 ;

48 ;

49 ;
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50 (scriptfuregister

51 "scriptfuMLOcontrastlayer"

52 "<Image>/ScriptFu/Contrast/Add Contrast Layer"

53 "Add a contrast layer to an image, i.e. a second layer

54 obtained converting the original image to B/W, then

55 inverting and blurring it. That sequence lowers the

56 contrast and lighten the shadows."

57 "Maurizio Loreti (Maurizio.Loreti@gmail.com)"

58 "2008, Maurizio Loreti, Padova, Italy"

59 "21Oct2008"

60 "*"

61 SFIMAGE "The image" 0

62 SFDRAWABLE "The layer" 0

63 SFADJUSTMENT "Gaussian blur radius" ’(25 1 100 1 10 0 0)

64 SFADJUSTMENT "Contrast layer opacity" ’(80 0 100 1 10 0 0)

65 SFTOGGLE "Flatten image" FALSE

66 )

67 ;

68 ; End of mlocontrastlayer

mlocontrastlayer.scm

A.2 Script per sovrapporre l’immagine sfocata

mloblurlayer.scm

1 ; Author: Maurizio Loreti, aka MLO or (HAM) I3NOO

2 ; Work: University of Padova  Department of Physics

3 ; Via F. Marzolo, 8  35131 PADOVA  Italy

4 ; Phone: +39 (049) 8277216 FAX: +39 (049) 8277102

5 ; EMail: Maurizio.Loreti@gmail.com

6 ; WWW: http://www.pd.infn.it/~loreti/mlo.html

7 ;

8 ;

9 ; Scriptfu programs for image handling with GIMP: blur mask

10 ;

11 ; $Id: mloblurlayer.scm,v 1.4 2008/11/16 10:08:22 loreti Exp $

12 ;

13 ;

14 ; myduplicatelayer (borrowed from David Meiklejohn & Harry Phillips)

15 ;

16 (define (myduplicatelayer image layer)

17 (let* ((duplayer (car (gimplayercopy layer 1))))

18 (gimpimageaddlayer image duplayer 0)

19 duplayer))

20 ;

21 ;

22 ;

23 (define (scriptfuMLOblurlayer

24 InImage InLayer InRadius InOpacity InFlatten)

25 ; save history

26 (gimpimageundogroupstart InImage)

27 ; duplicate layer

28 (let (

29 (blur (myduplicatelayer InImage InLayer))

30 )

31 (gimplayersetname blur "BlurMask")

32 ; Gaussian blur on the new layer
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33 (plugingauss 1 InImage blur InRadius InRadius 1)

34 ; set opacity to the preset value, and layer mode to overlay

35 (gimplayersetopacity blur InOpacity)

36 (gimplayersetmode blur OVERLAY)

37 ; flatten image?

38 (if (= InFlatten TRUE) (gimpimageflatten InImage))

39 ; finish

40 (gimpimageundogroupend InImage)

41 (gimpdisplaysflush)

42 )

43 )

44 ;

45 ;

46 ;

47 (scriptfuregister

48 "scriptfuMLOblurlayer"

49 "<Image>/ScriptFu/Contrast/Add Blur Layer"

50 "Adds a blur layer to an image, i.e. a second layer obtained

51 duplicating the original image and blurring it. That sequence

52 increases the contrast and the saturation."

53 "Maurizio Loreti (Maurizio.Loreti@gmail.com)"

54 "2008, Maurizio Loreti, Padova, Italy"

55 "21Oct2008"

56 "*"

57 SFIMAGE "The image" 0

58 SFDRAWABLE "The layer" 0

59 SFADJUSTMENT "Gaussian blur radius" ’(25 1 100 1 10 0 0)

60 SFADJUSTMENT "Blur layer opacity" ’(80 0 100 1 10 0 0)

61 SFTOGGLE "Flatten image" FALSE

62 )

63 ;

64 ; End of mloblurlayer

mloblurlayer.scm


